Rails 2 Incompatibility #41

Closed
mgomes opened this Issue Jul 18, 2011 · 1 comment

Projects

None yet

2 participants

@mgomes
mgomes commented Jul 18, 2011

Starting with versions > 0.3.0 activemodel has been listed as a dependency. It tries to pull down activesupport > 3.0.0 which generally makes this gem incompatible with Rails 2. Is there any way to skip listing that dependency in the gemspec?

@mgomes
mgomes commented Jul 18, 2011

I've went through the gem and it looks like removing activemodel at this stage would be really involved. It seems all of the validation code is now piggy-backing off of activemodel. It might just be worth mentioning in the README that this gem is no longer compatible with Rails 2 since version 0.3.0.

@langalex langalex closed this Aug 12, 2011
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment