Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Make therubyracer a runtime dependency to fix load errors (v8) #63

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
2 participants
Contributor

matthiasjakel commented May 24, 2012

When I use the couch_potato/rspec matchers in my application to test custom map functions etc. I get errors because v8 is required but could not get loaded. Making therubyracer (and libv8) a runtime dependency fixes the error.

Owner

langalex commented May 25, 2012

Sorry but this would lead to installing therubyracer on production machines even though it isn't needed. You can just add it to the test group of your Gemfile and your specs will pass.

@langalex langalex closed this May 25, 2012

Contributor

matthiasjakel commented May 25, 2012

Ok when not adding it as a dependency we should add that to the readme.

Owner

langalex commented May 25, 2012

feel free to do that :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment