New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Review per-project homestead instructions for homestead #2957

Closed
seanmangar opened this Issue Jan 8, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@seanmangar

seanmangar commented Jan 8, 2017

I'm proposing a small change to the per-project homestead instructions.

Recently after running composer update, my homestead updated from 3.0.2 to 3.1.* and my vagrant box could no longer start up. I initially had no idea the homestead update was causing this as the error was thrown by vagrant. Turns out this happened because I had initially followed the per-project homestead instructions, but was using an outdated box.

Environment:
Vagrant box: laravel/homestead (virtualbox, 0.5.0)
PHP version in box: PHP 7.0.3-13
Laravel framework: 5.2.45
Homestead: 3.1.0

Some suggestions would be:

  1. To run composer require laravel/homestead --dev with the right version for the vagrant box being used. E.g composer require laravel/homestead:3.0.* --dev. The reason being that this can lead to unexpected errors if used with outdated vagrant boxes as happened in my case.
  2. Make it clearer that there are compatibilities to be followed depending on the vagrant box being used. https://laravel.com/docs/5.3/homestead#old-versions . We could also add a row that box 0.5.0 is only compatible with homestead 3.0.2.

Let me know what you guys think.
@taylorotwell: I would like your input on this please.

@svpernova09

This comment has been minimized.

Show comment
Hide comment
@svpernova09

svpernova09 Dec 1, 2017

Member

Sorry for the ridiculous delay in responding.

You should always run the most recent version. I just opened a PR to remove the old version documentation because now that Homestead supports all current supported PHP versions, there should be no need to use older Homestead versions or Base boxes.

Thanks.

Member

svpernova09 commented Dec 1, 2017

Sorry for the ridiculous delay in responding.

You should always run the most recent version. I just opened a PR to remove the old version documentation because now that Homestead supports all current supported PHP versions, there should be no need to use older Homestead versions or Base boxes.

Thanks.

@svpernova09 svpernova09 closed this Dec 5, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment