Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[6.x] Set minimum Guzzle version for PHP 8 CI #35267

Merged
merged 3 commits into from Nov 18, 2020
Merged

[6.x] Set minimum Guzzle version for PHP 8 CI #35267

merged 3 commits into from Nov 18, 2020

Conversation

GrahamCampbell
Copy link
Member

@GrahamCampbell GrahamCampbell commented Nov 18, 2020

This will fix the recent test failures (such as in #35266). The reason for this work around is Guzzle 6 does not have an upper bound on it's required PHP version, and only Guzzle 7.2.0 or higher will run on PHP 8.0.

I've also corrected the AWS SDK minimum version to be the first that will support S3 on PHP 8 (ish... their tests are actually failing on PHP 8 still) and also work with Guzzle 7.

@GrahamCampbell GrahamCampbell marked this pull request as draft Nov 18, 2020
@GrahamCampbell GrahamCampbell marked this pull request as ready for review Nov 18, 2020
@GrahamCampbell GrahamCampbell requested a review from driesvints Nov 18, 2020
@taylorotwell taylorotwell merged commit e90889d into 6.x Nov 18, 2020
34 checks passed
@driesvints driesvints deleted the guzzle-php8 branch Nov 18, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants