New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Attempted to load class "ConstraintValidator" from namespace "Symfony\Component\Validator". Did you forget a "use" statement for another namespace? #997

Closed
engharb opened this Issue Dec 5, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@engharb

engharb commented Dec 5, 2018

Please note that the Homestead issue tracker is reserved for bug reports and enhancements. We are not always able to debug Vagrant, Provider or Operating System issues, but will do our best to help. Thank you!

Versions

  • Vagrant: 2.2.2.
  • Provider: Virtualbox 5.2.22.
  • Homestead: latest version.

Host operating system

Mac OS

Homestead.yaml

ip: "192.168.33.12"
memory: 2048
cpus: 1
hostname: mywebsite
name: mywebsite
provider: virtualbox

authorize: ~/.ssh/id_rsa.pub
keys:
    - ~/.ssh/id_rsa

folders:
    - map: "~/svn/app/mywebsite"
      to: "/home/vagrant/mywebsite"
      type: "nfs"

sites:
    - map: mywebsite.de
      to: "/home/vagrant/mywebsite/public"
      type: test
      php: "7.2"

databases:
    - homestead
    - test
    - symfony

Expected behavior

after vagrant ssh I want to install packages using composer install

Actual behavior

in VM I tried composer install successfully but one of symfony4 classes is not installed or copied under vendor/symfony/validator

Class name is ConstraintValidator

Also the composer install result is success with no failure. I'm afraid about such problem if it comes because of nfs or file synchronization or caches.!?

I tried to clear composer cache locally and in VM but that does not work too.

Steps to reproduce

  1. vagrant up
  2. vagrant ssh
  3. composer install
@svpernova09

This comment has been minimized.

Member

svpernova09 commented Dec 5, 2018

Without more info it sounds like a problem with your composer.json. Doesn't sound like anything is wrong with Homestead.

@engharb engharb closed this Dec 5, 2018

@engharb

This comment has been minimized.

engharb commented Dec 5, 2018

Just incompatibility with macOS version. I just upgraded OS.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment