Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[WIP] [6.x] Use laravel/tinker v2 #5161

Merged
merged 1 commit into from Nov 26, 2019

Conversation

@GrahamCampbell
Copy link
Member

GrahamCampbell commented Nov 25, 2019

To be merged when tinker v2 is ready. This can then make it into 7.x by merging master -> develop in the usual way.

@GrahamCampbell GrahamCampbell requested a review from driesvints Nov 25, 2019
@crynobone

This comment has been minimized.

Copy link
Contributor

crynobone commented Nov 26, 2019

Why not "laravel/tinker": "^1.0|^2.0" if isn't non breaking changes.

@driesvints

This comment has been minimized.

Copy link
Member

driesvints commented Nov 26, 2019

@crynobone because the skeleton is only used for new installs and new laravel 6 installs will be compatible with tinker 2

@GrahamCampbell

This comment has been minimized.

Copy link
Member Author

GrahamCampbell commented Nov 26, 2019

Exactly. This is not the framework repo. People can edit their app's composer.json after making a new app if they want. :)

@crynobone

This comment has been minimized.

Copy link
Contributor

crynobone commented Nov 26, 2019

Just that without tinker v2, I can't sync Testbench 5.x with Laravel dev-develop skeleton anytime soon.

@GrahamCampbell

This comment has been minimized.

Copy link
Member Author

GrahamCampbell commented Nov 26, 2019

The dependencies of tinker don't support Symfony 5 yet.

@taylorotwell taylorotwell merged commit b56fe84 into master Nov 26, 2019
2 checks passed
2 checks passed
continuous-integration/styleci/pr The analysis has passed
Details
continuous-integration/styleci/push The analysis has passed
Details
@GrahamCampbell

This comment has been minimized.

Copy link
Member Author

GrahamCampbell commented Nov 26, 2019

This was really merged too soon, since psysh 0.9.x may never support Symfony 5.

@GrahamCampbell GrahamCampbell deleted the tinker branch Nov 26, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.