No description, website, or topics provided.
PHP
Switch branches/tags
Nothing to show
Clone or download
taylorotwell Merge pull request #3 from clod986/master
Update composer.json to require Laravel >= 5.3
Latest commit 0e53ea5 May 24, 2017
Permalink
Failed to load latest commit information.
src first Aug 3, 2016
.editorconfig first Aug 3, 2016
.gitattributes first Aug 3, 2016
.gitignore first Aug 3, 2016
LICENSE.txt first Aug 3, 2016
composer.json Update composer.json May 24, 2017
example.php first Aug 3, 2016
readme.md Readme Aug 3, 2016

readme.md

Laravel Legacy Encrypter

This encryption package provides support for the legacy Mcrypt encrypter used by Laravel 5.0 through 5.2. It is primarily intended to be used to migrate your data to the new OpenSSL based encrypter used in 5.1 through the latest release of Laravel.

Usage Example

use Laravel\LegacyEncrypter\McryptEncrypter;

$encrypter = new McryptEncrypter($encryptionKey);

$encrypted = $encrypter->encrypt('I am encrypted!');

$decrypted = $encrypter->decrypt($encrypted);