New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[v3] Google+ APIs being shutdown #317

Closed
fhriz opened this Issue Dec 21, 2018 · 13 comments

Comments

Projects
None yet
8 participants
@fhriz
Copy link

fhriz commented Dec 21, 2018

Hi,

I'm still using laravel 5.4 for php version reason. But, I got an email which saying that Google+ APIs being shutdown. But, unfortunately the changes are made for v4. Could you help me how I can use the changes which made in #283 for v3 ?

Thanks

@olafnorge

This comment has been minimized.

Copy link

olafnorge commented Dec 21, 2018

For me it's because of using the LTS but socialite v4 would force me to bump the full stack to at least laravel 5.7 which I don't really want to.

@dionmes

This comment has been minimized.

Copy link

dionmes commented Dec 21, 2018

Same here, still on 5.5 because of the LTS. I also got the email from Google that 'plus.people.get' method is being called and its deprecated.

@driesvints driesvints closed this Dec 21, 2018

@driesvints

This comment has been minimized.

Copy link
Member

driesvints commented Dec 21, 2018

Pr got merged. You can pull in 3.0.x-dev if you like.

@kennith

This comment has been minimized.

Copy link

kennith commented Dec 26, 2018

@driesvints Thanks. Do you know if the merged PR will be released under 3.2.1?

@driesvints

This comment has been minimized.

Copy link
Member

driesvints commented Jan 2, 2019

@kennith since we don't support 3.0 anymore probably not

@kidager

This comment has been minimized.

Copy link

kidager commented Jan 3, 2019

@kennith since we don't support 3.0 anymore probably not

@driesvints I don't understand, if Laravel 5.5 is LTS (and is still supported) and it uses Socialite ^3.0, shouldn't it still be supported too ? If not what's the point of it being an LTS version if used laravel libraries aren't.

Following that logic, someone creating a fresh laravel project using version 5.5 (I'm totally against, but it is still supported) will not be able to install a working version of Socialite, v4 requires Laravel 5.7, and v3 isn't supported anymore!

@driesvints

This comment has been minimized.

Copy link
Member

driesvints commented Jan 3, 2019

@kidager LTS only applies for the framework and not the other libraries.

@iamacarpet

This comment has been minimized.

Copy link

iamacarpet commented Jan 3, 2019

@kidager LTS only applies for the framework and not the other libraries.

@driesvints don't you think this is why people think PHP for the enterprise is a joke?

It's only a 30 seconds job to do a release on GitHub so it gets picked up automatically by composer, with no negative impacts for anyone else, not like people are asking the earth here - it would have taken less time to just do it than reply twice. Why bother accepting the PR if you won't bother with a release?

@GrahamCampbell

This comment has been minimized.

Copy link
Member

GrahamCampbell commented Jan 3, 2019

don't you think this is why people think PHP for the enterprise is a joke?

PHP has one of the best package ecosystems of any language actually, so I disagree.

@kidager

This comment has been minimized.

Copy link

kidager commented Jan 3, 2019

PHP has one of the best package ecosystems of any language actually, so I disagree.

I totally agree with you there. But this is going to be a critical bug for every Socialite user managing a Laravel installation of v5.6 or less (Keeping always in mind that 5.5 is still supported and that laravel/socialite is part of laravel, not included by default, but still a part of the laravel ecosystem)

So seeing that a simple fix won't be applied for a library we're using in prod does not make me want to use it anymore! Even with the newer versions.

And we all agree here that a fix on the application part (a hack for short) is not something complicated, it's enough to replace the class in the container. But that's not the point, the point is the PR is accepted but won't be applied which ignores totally the users base need. No one will reference a "dev" version in their prod environment.

@driesvints

This comment has been minimized.

Copy link
Member

driesvints commented Jan 3, 2019

@kidager we merged the pr and you can require it with Composer by requiring 3.0.x-dev like I said above.

@kidager

This comment has been minimized.

Copy link

kidager commented Jan 3, 2019

@kidager we merged the pr and you can require it with Composer by requiring 3.0.x-dev like I said above.

No one will reference a "dev" version in their prod environment.

@driesvints

This comment has been minimized.

Copy link
Member

driesvints commented Jan 3, 2019

Honestly, if all you're going to do is complain it's best that we just lock this.

@laravel laravel locked and limited conversation to collaborators Jan 3, 2019

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.