Permalink
Commits on May 5, 2018
  1. Prepare release 0.6.4

    larskanis committed May 5, 2018
  2. Update libusb to 1.0.22

    larskanis committed May 5, 2018
Commits on Feb 23, 2018
  1. Don't require development package on Linux

    larskanis committed Feb 23, 2018
    Add the ABI version number "0" used by the libusb library package
    on Linux dists, so that it's not necessary to install the
    corresponding development package.
Commits on Jan 12, 2018
  1. Add some missing attribute readers to Transfer

    larskanis committed Jan 12, 2018
    ... and verify that dev_handle is set before using it.
  2. Avoid warning about uninitialzed variable @dev_handle

    larskanis committed Jan 12, 2018
    ... in Transfer#ensure_enough_buffer
  3. Remove test_libusb_context from "rake travis"

    larskanis committed Jan 12, 2018
    It fails with LIBUSB_ERROR_OTHER there, because it has no USB.
  4. Update History.md [ci skip]

    larskanis committed Jan 12, 2018
  5. Merge capability and version tests into test_libusb.rb

    larskanis committed Jan 12, 2018
  6. Add libusb_set_option() wrapper, new in libusb-1.0.22

    larskanis committed Jan 12, 2018
    This deprecates Context#set_debug and adds Context#set_option instead.
    If libusb.gem is linked to an older libusb library, #set_option is
    provided on top of libusb_set_debug() as a fallback.
  7. Add yard as development dependency and as doc generator

    larskanis committed Jan 12, 2018
    ... in the gemspec.
  8. Update libusb to 1.0.22-rc1

    larskanis committed Jan 12, 2018
  9. Add definition for SUPER_SPEED_PLUS

    larskanis committed Jan 12, 2018
    Also add some description as comment.
Commits on Dec 25, 2017
  1. Update ruby versions on travis-ci

    larskanis committed Dec 25, 2017
  2. Add mini_portile2 to the Gemfile

    larskanis committed Dec 25, 2017
  3. Force source gem installation

    larskanis committed Dec 25, 2017
    ... because ffi is not yet prepared for ruby-2.5 and bundler
    still can't resolve this.
  4. Remove unneeded ENV variable RUBYDOWNLOAD

    larskanis committed Dec 25, 2017
Commits on Dec 24, 2017
  1. Appveyor: Add ruby-head to test matrix

    larskanis committed Dec 24, 2017
Commits on Aug 20, 2017
  1. Update release date in History.md

    larskanis committed Aug 20, 2017
  2. Fix compat with FreeBSD

    larskanis committed Aug 20, 2017
    FreeBSD uses libusb.so file for both libusb-0.x and libusb-1.x
    
    Fixes #24
  3. Show badge icons for master branch instead of last build

    larskanis committed Aug 20, 2017
Commits on Aug 19, 2017
  1. Update CI for Ruby-2.4.1

    larskanis committed Aug 19, 2017
Commits on Feb 4, 2017
  1. Appveyor: Install SSL_CERT_FILE to avoid SSL certificate error

    larskanis committed Feb 4, 2017
Commits on Jan 13, 2017
  1. Update release date in History.md

    larskanis committed Jan 13, 2017
  2. Add History entry for 0.6.2

    larskanis committed Jan 13, 2017
  3. Bump VERSION to 0.6.2.

    larskanis committed Jan 13, 2017
  4. Use -static-libgcc to avoid references to non-Windows system DLLs.

    larskanis committed Jan 13, 2017
    Libtool removes this option, so we use the trick described here:
      http://www.mingw.org/wiki/HOWTO_Sneak_GCC_Switches_Past_Libtool
    
    This fixes #22 .