Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Move development dependencies into the Gemfile

  • Loading branch information...
commit 1379659e991bffb8b363fddc0f079d81f41a9525 1 parent ca48bb3
@laserlemon authored
View
27 Gemfile
@@ -1,13 +1,18 @@
-source 'https://rubygems.org'
+source "https://rubygems.org"
-if RUBY_VERSION == '1.8.7'
- gem 'factory_girl', '~> 2.0'
-end
-
-gemspec :name => 'periscope'
-gemspec :name => 'periscope-activerecord'
-gemspec :name => 'periscope-mongo_mapper'
-gemspec :name => 'periscope-mongoid'
-gemspec :name => 'periscope-data_mapper'
+gemspec name: "periscope"
+gemspec name: "periscope-activerecord"
+gemspec name: "periscope-data_mapper"
+gemspec name: "periscope-mongo_mapper"
+gemspec name: "periscope-mongoid"
-gem 'rake', '~> 0.9.0'
+group :test do
+ gem "bson_ext", "~> 1.8"
+ gem "database_cleaner", "~> 0.9"
+ gem "dm-migrations", "~> 1.2"
+ gem "dm-sqlite-adapter", "~> 1.2"
+ gem "factory_girl", "~> 4.2"
+ gem "rake", "~> 10.0"
+ gem "rspec", "~> 2.13"
+ gem "sqlite3", "~> 1.3"
+end
View
5 periscope-activerecord.gemspec
@@ -13,11 +13,6 @@ Gem::Specification.new do |gem|
gem.add_dependency 'activerecord', '~> 3.0'
gem.add_dependency 'periscope', '~> 1.0'
- gem.add_development_dependency 'database_cleaner', '~> 0.8'
- gem.add_development_dependency 'factory_girl', '>= 2', '< 5'
- gem.add_development_dependency 'rspec', '~> 2.0'
- gem.add_development_dependency 'sqlite3'
-
gem.files = %w(
LICENSE
lib/periscope-activerecord.rb
View
7 periscope-data_mapper.gemspec
@@ -13,13 +13,6 @@ Gem::Specification.new do |gem|
gem.add_dependency 'dm-core', '~> 1.0'
gem.add_dependency 'periscope', '~> 1.0'
- gem.add_development_dependency 'database_cleaner', '~> 0.8'
- gem.add_development_dependency 'dm-migrations', '~> 1.0'
- gem.add_development_dependency 'dm-sqlite-adapter', '~> 1.0'
- gem.add_development_dependency 'factory_girl', '>= 2', '< 5'
- gem.add_development_dependency 'rspec', '~> 2.0'
- gem.add_development_dependency 'sqlite3'
-
gem.files = %w(
LICENSE
lib/periscope-data_mapper.rb
View
5 periscope-mongo_mapper.gemspec
@@ -13,11 +13,6 @@ Gem::Specification.new do |gem|
gem.add_dependency 'mongo_mapper', '~> 0.9'
gem.add_dependency 'periscope', '~> 1.0'
- gem.add_development_dependency 'bson_ext', '~> 1.4'
- gem.add_development_dependency 'database_cleaner', '~> 0.8'
- gem.add_development_dependency 'factory_girl', '>= 2', '< 5'
- gem.add_development_dependency 'rspec', '~> 2.0'
-
gem.files = %w(
LICENSE
lib/periscope-mongo_mapper.rb
View
4 periscope-mongoid.gemspec
@@ -13,10 +13,6 @@ Gem::Specification.new do |gem|
gem.add_dependency 'mongoid', '>= 2', '< 4'
gem.add_dependency 'periscope', '~> 1.0'
- gem.add_development_dependency 'database_cleaner', '~> 0.8'
- gem.add_development_dependency 'factory_girl', '>= 2', '< 5'
- gem.add_development_dependency 'rspec', '~> 2.0'
-
gem.files = %w(
LICENSE
lib/periscope-mongoid.rb
View
2  periscope.gemspec
@@ -10,8 +10,6 @@ Gem::Specification.new do |gem|
gem.summary = gem.description
gem.homepage = 'https://github.com/laserlemon/periscope'
- gem.add_development_dependency 'rspec', '~> 2.0'
-
gem.files = %w(
LICENSE
lib/periscope.rb
Please sign in to comment.
Something went wrong with that request. Please try again.