Permalink
Browse files

Clean up mongoid gemfiles and add gemfiles for missing versions

  • Loading branch information...
1 parent cec9f31 commit 6e80130aed9acefc6bccbbedf1e2377de948fca9 @laserlemon committed Mar 6, 2013
@@ -1,11 +1,12 @@
-source 'https://rubygems.org'
+source "https://rubygems.org"
-if RUBY_VERSION == '1.8.7'
- gem 'factory_girl', '~> 2.0'
-end
-
-gem 'mongoid', '~> 2.0.0'
+gem "mongoid", "~> 2.0.0"
-gemspec :name => 'periscope-mongoid', :path => '../../'
+gemspec name: "periscope-mongoid", path: "../../"
-gem 'rake', '~> 0.9.0'
+group :test do
+ gem "database_cleaner", "~> 0.9"
+ gem "factory_girl", "~> 4.2"
+ gem "rake", "~> 10.0"
+ gem "rspec", "~> 2.13"
+end
@@ -1,11 +1,12 @@
-source 'https://rubygems.org'
+source "https://rubygems.org"
-if RUBY_VERSION == '1.8.7'
- gem 'factory_girl', '~> 2.0'
-end
-
-gem 'mongoid', '~> 2.1.0'
+gem "mongoid", "~> 2.1.0"
-gemspec :name => 'periscope-mongoid', :path => '../../'
+gemspec name: "periscope-mongoid", path: "../../"
-gem 'rake', '~> 0.9.0'
+group :test do
+ gem "database_cleaner", "~> 0.9"
+ gem "factory_girl", "~> 4.2"
+ gem "rake", "~> 10.0"
+ gem "rspec", "~> 2.13"
+end
@@ -1,11 +1,12 @@
-source 'https://rubygems.org'
+source "https://rubygems.org"
-if RUBY_VERSION == '1.8.7'
- gem 'factory_girl', '~> 2.0'
-end
-
-gem 'mongoid', '~> 2.2.0'
+gem "mongoid", "~> 2.2.0"
-gemspec :name => 'periscope-mongoid', :path => '../../'
+gemspec name: "periscope-mongoid", path: "../../"
-gem 'rake', '~> 0.9.0'
+group :test do
+ gem "database_cleaner", "~> 0.9"
+ gem "factory_girl", "~> 4.2"
+ gem "rake", "~> 10.0"
+ gem "rspec", "~> 2.13"
+end
@@ -1,11 +1,12 @@
-source 'https://rubygems.org'
+source "https://rubygems.org"
-if RUBY_VERSION == '1.8.7'
- gem 'factory_girl', '~> 2.0'
-end
-
-gem 'mongoid', '~> 2.3.0'
+gem "mongoid", "~> 2.3.0"
-gemspec :name => 'periscope-mongoid', :path => '../../'
+gemspec name: "periscope-mongoid", path: "../../"
-gem 'rake', '~> 0.9.0'
+group :test do
+ gem "database_cleaner", "~> 0.9"
+ gem "factory_girl", "~> 4.2"
+ gem "rake", "~> 10.0"
+ gem "rspec", "~> 2.13"
+end
@@ -1,11 +1,12 @@
-source 'https://rubygems.org'
+source "https://rubygems.org"
-if RUBY_VERSION == '1.8.7'
- gem 'factory_girl', '~> 2.0'
-end
-
-gem 'mongoid', '~> 2.4.0'
+gem "mongoid", "~> 2.4.0"
-gemspec :name => 'periscope-mongoid', :path => '../../'
+gemspec name: "periscope-mongoid", path: "../../"
-gem 'rake', '~> 0.9.0'
+group :test do
+ gem "database_cleaner", "~> 0.9"
+ gem "factory_girl", "~> 4.2"
+ gem "rake", "~> 10.0"
+ gem "rspec", "~> 2.13"
+end
@@ -0,0 +1,12 @@
+source "https://rubygems.org"
+
+gem "mongoid", "~> 2.5.0"
+
+gemspec name: "periscope-mongoid", path: "../../"
+
+group :test do
+ gem "database_cleaner", "~> 0.9"
+ gem "factory_girl", "~> 4.2"
+ gem "rake", "~> 10.0"
+ gem "rspec", "~> 2.13"
+end
@@ -0,0 +1,12 @@
+source "https://rubygems.org"
+
+gem "mongoid", "~> 2.6.0"
+
+gemspec name: "periscope-mongoid", path: "../../"
+
+group :test do
+ gem "database_cleaner", "~> 0.9"
+ gem "factory_girl", "~> 4.2"
+ gem "rake", "~> 10.0"
+ gem "rspec", "~> 2.13"
+end
@@ -1,11 +1,12 @@
-source 'https://rubygems.org'
+source "https://rubygems.org"
-if RUBY_VERSION == '1.8.7'
- gem 'factory_girl', '~> 2.0'
-end
-
-gem 'mongoid', '~> 3.0.0'
+gem "mongoid", "~> 3.0.0"
-gemspec :name => 'periscope-mongoid', :path => '../../'
+gemspec name: "periscope-mongoid", path: "../../"
-gem 'rake', '~> 0.9.0'
+group :test do
+ gem "database_cleaner", "~> 0.9"
+ gem "factory_girl", "~> 4.2"
+ gem "rake", "~> 10.0"
+ gem "rspec", "~> 2.13"
+end
@@ -0,0 +1,12 @@
+source "https://rubygems.org"
+
+gem "mongoid", "~> 3.1.0"
+
+gemspec name: "periscope-mongoid", path: "../../"
+
+group :test do
+ gem "database_cleaner", "~> 0.9"
+ gem "factory_girl", "~> 4.2"
+ gem "rake", "~> 10.0"
+ gem "rspec", "~> 2.13"
+end

0 comments on commit 6e80130

Please sign in to comment.