Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Rendered Markdown hyperlinks are preceeded with Joplin "J" logo. #1864

Closed
deisner opened this issue Sep 9, 2019 · 3 comments

Comments

@deisner
Copy link

commented Sep 9, 2019

Environment

Joplin version: 1.0.66 (prod, win32)
Platform: Windows
OS specifcs: Windows 10 Enterprise v. 1903

Steps To Reproduce

  1. Add a hyperlink to a Markdown note, where the URL does not end in a forward slash.

Describe what you expected to happen:

I expect to see the link rendered without a Joplin 'J' logo character, but one is there. If I add a trailing slash to the URL, there is no 'J' logo.

image

Logfile

There's an error in the devtools console, but I think it's unrelated -- the error happens even if I don't use Ctrl+K to add the URL.

image

No errors in log.txt.

@deisner deisner added the bug label Sep 9, 2019

@laurent22 laurent22 added the essential label Sep 9, 2019

@genneko

This comment has been minimized.

Copy link
Contributor

commented Sep 10, 2019

I see this on 1.0.166, too. A URL rendered with "J" logo looks clickable but doesn't work as a hyperlink.

@seth100

This comment has been minimized.

Copy link

commented Sep 10, 2019

Yes I have this issue too. All of my links now are not clickable anymore O.o, it says something like "element with ID ... does not exist".
Android latest version 1.0.304.

@laurent22

This comment has been minimized.

Copy link
Owner

commented Sep 10, 2019

Fixed in e03ef78

@laurent22 laurent22 closed this Sep 10, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.