Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Move to EAPI 4, proper DEPENDs, simpler install

  • Loading branch information...
commit 75c486bd7454d64c33656164d43c405c9698ec60 1 parent c5cb377
@laurentb authored
Showing with 4 additions and 8 deletions.
  1. +4 −8 app-text/dictator/dictator-0.9.7.ebuild
View
12 app-text/dictator/dictator-0.9.7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
+EAPI=4
PYTHON_DEPEND="2:2.5"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
@@ -17,18 +17,14 @@ LICENSE="GPL-2"
KEYWORDS="~x86 ~amd64"
IUSE=""
-DEPEND="
- >=x11-libs/gtk+-2.4
+DEPEND=""
+RDEPEND=">=x11-libs/gtk+-2.4
>=dev-python/wxpython-2.4.2.4"
src_prepare() {
- default
mkdir bin
mv "dictator_start.py" "bin/dictator"
sed -i 's#dictator_start\.py#bin/dictator#' "setup.py"
}
-src_install() {
- distutils_src_install
- dodoc doc/*
-}
+DOCS="doc/*"
Please sign in to comment.
Something went wrong with that request. Please try again.