Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Update dev-vcs/legit to 0.1.0

  • Loading branch information...
commit 8790b3cdd33d4e3c9edef9d4e242e6aebdb95bf5 1 parent e535cd9
@laurentb authored
View
2  dev-vcs/legit/Manifest
@@ -1 +1 @@
-DIST legit-0.0.9.tar.gz 6821 RMD160 41b5ebfd0017333b34bd88a6909b1085a8628812 SHA1 014667bb6affc58987947222ea923263091b8590 SHA256 65ae16d8d764121a84cb8dbf4f8503cb113ac7891cbd4be597afdfb25f5c7ba3
+DIST legit-0.1.0.tar.gz 9864 RMD160 584b8457d1ed3a5b2dae4ef1a374742e97c8f2e8 SHA1 9cab1877a9ffc569d9f7a19891ef462b8aa07881 SHA256 72ad33014c289d18aa6655bb62588d090f33e965fca2737f2bcef9db0dc371d0
View
36 dev-vcs/legit/files/0001-Remove-unused-dependencies.patch
@@ -0,0 +1,36 @@
+From b8a1e121801ce0fbe80b9dda59e201ff98356501 Mon Sep 17 00:00:00 2001
+From: Laurent Bachelier <laurent@bachelier.name>
+Date: Thu, 22 Mar 2012 02:22:33 +0100
+Subject: [PATCH 1/3] Remove unused dependencies
+
+---
+ legit/bootstrap.py | 2 --
+ reqs.txt | 3 ---
+ 2 files changed, 0 insertions(+), 5 deletions(-)
+
+diff --git a/legit/bootstrap.py b/legit/bootstrap.py
+index 39e25cd..d9c96a7 100644
+--- a/legit/bootstrap.py
++++ b/legit/bootstrap.py
+@@ -12,8 +12,6 @@ import ConfigParser
+
+
+ import clint.textui.colored
+-import requests
+-import omnijson
+ from clint import resources
+ from clint.textui import colored
+
+diff --git a/reqs.txt b/reqs.txt
+index e84e40f..af2f730 100644
+--- a/reqs.txt
++++ b/reqs.txt
+@@ -1,5 +1,2 @@
+ clint==0.2.4
+ gitpython
+-
+-requests
+-omnijson
+--
+1.7.3.4
+
View
23 dev-vcs/legit/files/0002-Require-minimum-versions.patch
@@ -0,0 +1,23 @@
+From 98ec4325ace43daa68e1a02af13e60d821398ff6 Mon Sep 17 00:00:00 2001
+From: Laurent Bachelier <laurent@bachelier.name>
+Date: Thu, 22 Mar 2012 02:25:29 +0100
+Subject: [PATCH 2/3] Require minimum versions
+
+* No reason to want an exact version of clint, use latest
+* Older gitpython versions miss git.exc.GitCommandError (at least)
+---
+ reqs.txt | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/reqs.txt b/reqs.txt
+index af2f730..1193048 100644
+--- a/reqs.txt
++++ b/reqs.txt
+@@ -1,2 +1,2 @@
+-clint==0.2.4
+-gitpython
++clint>=0.2.4
++gitpython>=0.3.0
+--
+1.7.3.4
+
View
5 dev-vcs/legit/legit-0.0.9.ebuild → dev-vcs/legit/legit-0.1.0.ebuild
@@ -6,7 +6,7 @@ PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
-inherit distutils
+inherit eutils distutils
DESCRIPTION="A git CLI tool to manage branches easily."
HOMEPAGE="https://github.com/kennethreitz/legit
@@ -25,5 +25,6 @@ RDEPEND=">=dev-python/git-python-0.3.0
DOCS="README.rst LICENSE"
src_prepare() {
- sed -i 's/==.\+//' reqs.txt
+ epatch "${FILESDIR}/0001-Remove-unused-dependencies.patch"
+ epatch "${FILESDIR}/0002-Require-minimum-versions.patch"
}
Please sign in to comment.
Something went wrong with that request. Please try again.