Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Adding more needed development dependencies, bumping gem version

  • Loading branch information...
commit 68286d689d956abe17f77e9e5b7c9537e8530bbc 1 parent c7b84ad
@jasonm jasonm authored
Showing with 26 additions and 11 deletions.
  1. +5 −1 Rakefile
  2. +1 −1  lib/paperclip.rb
  3. +20 −9 paperclip.gemspec
View
6 Rakefile
@@ -76,7 +76,11 @@ spec = Gem::Specification.new do |s|
s.rdoc_options << '--line-numbers' << '--inline-source'
s.requirements << "ImageMagick"
s.add_development_dependency 'thoughtbot-shoulda'
- s.add_development_dependency 'mocha'
+ s.add_development_dependency 'jferris-mocha', '= 0.9.5.0.1241126838'
+ s.add_development_dependency 'aws-s3'
+ s.add_development_dependency 'sqlite3-ruby'
+ s.add_development_dependency 'activerecord'
+ s.add_development_dependency 'activesupport'
end
desc "Print a list of the files to be put into the gem"
View
2  lib/paperclip.rb
@@ -45,7 +45,7 @@
# documentation for Paperclip::ClassMethods for more useful information.
module Paperclip
- VERSION = "2.3.1"
+ VERSION = "2.3.1.1"
class << self
# Provides configurability to Paperclip. There are a number of options available, such as:
View
29 paperclip.gemspec
@@ -2,36 +2,47 @@
Gem::Specification.new do |s|
s.name = %q{paperclip}
- s.version = "2.3.1"
+ s.version = "2.3.1.1"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Jon Yurek"]
- s.date = %q{2009-08-21}
+ s.date = %q{2009-10-09}
s.email = %q{jyurek@thoughtbot.com}
s.extra_rdoc_files = ["README.rdoc"]
- s.files = ["README.rdoc", "LICENSE", "Rakefile", "init.rb", "generators/paperclip", "generators/paperclip/paperclip_generator.rb", "generators/paperclip/templates", "generators/paperclip/templates/paperclip_migration.rb.erb", "generators/paperclip/USAGE", "lib/paperclip", "lib/paperclip/attachment.rb", "lib/paperclip/callback_compatability.rb", "lib/paperclip/geometry.rb", "lib/paperclip/interpolations.rb", "lib/paperclip/iostream.rb", "lib/paperclip/matchers", "lib/paperclip/matchers/have_attached_file_matcher.rb", "lib/paperclip/matchers/validate_attachment_content_type_matcher.rb", "lib/paperclip/matchers/validate_attachment_presence_matcher.rb", "lib/paperclip/matchers/validate_attachment_size_matcher.rb", "lib/paperclip/matchers.rb", "lib/paperclip/processor.rb", "lib/paperclip/storage.rb", "lib/paperclip/thumbnail.rb", "lib/paperclip/upfile.rb", "lib/paperclip.rb", "tasks/paperclip_tasks.rake", "test/attachment_test.rb", "test/database.yml", "test/fixtures", "test/fixtures/12k.png", "test/fixtures/50x50.png", "test/fixtures/5k.png", "test/fixtures/bad.png", "test/fixtures/s3.yml", "test/fixtures/text.txt", "test/fixtures/twopage.pdf", "test/geometry_test.rb", "test/helper.rb", "test/integration_test.rb", "test/interpolations_test.rb", "test/iostream_test.rb", "test/matchers", "test/matchers/have_attached_file_matcher_test.rb", "test/matchers/validate_attachment_content_type_matcher_test.rb", "test/matchers/validate_attachment_presence_matcher_test.rb", "test/matchers/validate_attachment_size_matcher_test.rb", "test/paperclip_test.rb", "test/processor_test.rb", "test/storage_test.rb", "test/thumbnail_test.rb", "shoulda_macros/paperclip.rb"]
- s.has_rdoc = true
+ s.files = ["README.rdoc", "LICENSE", "Rakefile", "init.rb", "generators/paperclip", "generators/paperclip/paperclip_generator.rb", "generators/paperclip/templates", "generators/paperclip/templates/paperclip_migration.rb.erb", "generators/paperclip/USAGE", "lib/paperclip", "lib/paperclip/attachment.rb", "lib/paperclip/callback_compatability.rb", "lib/paperclip/geometry.rb", "lib/paperclip/interpolations.rb", "lib/paperclip/iostream.rb", "lib/paperclip/matchers", "lib/paperclip/matchers/have_attached_file_matcher.rb", "lib/paperclip/matchers/validate_attachment_content_type_matcher.rb", "lib/paperclip/matchers/validate_attachment_presence_matcher.rb", "lib/paperclip/matchers/validate_attachment_size_matcher.rb", "lib/paperclip/matchers.rb", "lib/paperclip/processor.rb", "lib/paperclip/storage.rb", "lib/paperclip/thumbnail.rb", "lib/paperclip/upfile.rb", "lib/paperclip.rb", "tasks/paperclip_tasks.rake", "test/attachment_test.rb", "test/database.yml", "test/fixtures", "test/fixtures/12k.png", "test/fixtures/50x50.png", "test/fixtures/5k.png", "test/fixtures/bad.png", "test/fixtures/s3.yml", "test/fixtures/text.txt", "test/fixtures/twopage.pdf", "test/geometry_test.rb", "test/helper.rb", "test/integration_test.rb", "test/interpolations_test.rb", "test/iostream_test.rb", "test/matchers", "test/matchers/have_attached_file_matcher_test.rb", "test/matchers/validate_attachment_content_type_matcher_test.rb", "test/matchers/validate_attachment_presence_matcher_test.rb", "test/matchers/validate_attachment_size_matcher_test.rb", "test/paperclip_test.rb", "test/processor_test.rb", "test/storage_test.rb", "test/thumbnail_test.rb", "test/upfile_test.rb", "shoulda_macros/paperclip.rb"]
s.homepage = %q{http://www.thoughtbot.com/projects/paperclip}
s.rdoc_options = ["--line-numbers", "--inline-source"]
s.require_paths = ["lib"]
s.requirements = ["ImageMagick"]
s.rubyforge_project = %q{paperclip}
- s.rubygems_version = %q{1.3.1}
+ s.rubygems_version = %q{1.3.5}
s.summary = %q{File attachments as attributes for ActiveRecord}
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 2
+ s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
s.add_development_dependency(%q<thoughtbot-shoulda>, [">= 0"])
- s.add_development_dependency(%q<mocha>, [">= 0"])
+ s.add_development_dependency(%q<jferris-mocha>, ["= 0.9.5.0.1241126838"])
+ s.add_development_dependency(%q<aws-s3>, [">= 0"])
+ s.add_development_dependency(%q<sqlite3-ruby>, [">= 0"])
+ s.add_development_dependency(%q<activerecord>, [">= 0"])
+ s.add_development_dependency(%q<activesupport>, [">= 0"])
else
s.add_dependency(%q<thoughtbot-shoulda>, [">= 0"])
- s.add_dependency(%q<mocha>, [">= 0"])
+ s.add_dependency(%q<jferris-mocha>, ["= 0.9.5.0.1241126838"])
+ s.add_dependency(%q<aws-s3>, [">= 0"])
+ s.add_dependency(%q<sqlite3-ruby>, [">= 0"])
+ s.add_dependency(%q<activerecord>, [">= 0"])
+ s.add_dependency(%q<activesupport>, [">= 0"])
end
else
s.add_dependency(%q<thoughtbot-shoulda>, [">= 0"])
- s.add_dependency(%q<mocha>, [">= 0"])
+ s.add_dependency(%q<jferris-mocha>, ["= 0.9.5.0.1241126838"])
+ s.add_dependency(%q<aws-s3>, [">= 0"])
+ s.add_dependency(%q<sqlite3-ruby>, [">= 0"])
+ s.add_dependency(%q<activerecord>, [">= 0"])
+ s.add_dependency(%q<activesupport>, [">= 0"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.