Skip to content
Newer
Older
100644 72 lines (66 sloc) 2.19 KB
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
1 # Generated by jeweler
2 # DO NOT EDIT THIS FILE DIRECTLY
191fd45 @lautis Regenerate gemspec for version 0.4.0
authored Feb 26, 2011
3 # Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
4 # -*- encoding: utf-8 -*-
5
6 Gem::Specification.new do |s|
a8ebd4f @lautis Regenerate gemspec for version 1.0.4
authored Oct 18, 2011
7 s.name = "uglifier"
a358e5c @lautis Regenerate gemspec for version 1.2.0
authored Dec 15, 2011
8 s.version = "1.2.0"
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
9
10 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
85df942 @lautis Regenerate gemspec for version 1.0.1
authored Aug 15, 2011
11 s.authors = ["Ville Lautanala"]
a358e5c @lautis Regenerate gemspec for version 1.2.0
authored Dec 15, 2011
12 s.date = "2011-12-15"
a8ebd4f @lautis Regenerate gemspec for version 1.0.4
authored Oct 18, 2011
13 s.email = "lautis@gmail.com"
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
14 s.extra_rdoc_files = [
15 "LICENSE.txt",
16 "README.rdoc"
17 ]
18 s.files = [
19 ".document",
20 ".gitmodules",
21 ".rspec",
3763a3e @lautis Regenerate gemspec for version 1.0.0
authored Jun 21, 2011
22 ".travis.yml",
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
23 "Gemfile",
24 "LICENSE.txt",
25 "README.rdoc",
26 "Rakefile",
27 "VERSION",
075c3f7 @lautis Regenerate gemspec for version 0.5.0
authored Apr 7, 2011
28 "build.js",
564cc9c @lautis Include implementations of necessary ES5 functions
authored May 19, 2011
29 "lib/es5.js",
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
30 "lib/uglifier.rb",
075c3f7 @lautis Regenerate gemspec for version 0.5.0
authored Apr 7, 2011
31 "lib/uglify.js",
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
32 "spec/spec_helper.rb",
33 "spec/uglifier_spec.rb",
e9c66ae @lautis Don't include uncompiled uglifyjs in Gemfile
authored May 14, 2011
34 "uglifier.gemspec"
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
35 ]
a8ebd4f @lautis Regenerate gemspec for version 1.0.4
authored Oct 18, 2011
36 s.homepage = "http://github.com/lautis/uglifier"
85df942 @lautis Regenerate gemspec for version 1.0.1
authored Aug 15, 2011
37 s.require_paths = ["lib"]
a358e5c @lautis Regenerate gemspec for version 1.2.0
authored Dec 15, 2011
38 s.rubygems_version = "1.8.11"
a8ebd4f @lautis Regenerate gemspec for version 1.0.4
authored Oct 18, 2011
39 s.summary = "Ruby wrapper for UglifyJS JavaScript compressor"
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
40
41 if s.respond_to? :specification_version then
42 s.specification_version = 3
43
a8ebd4f @lautis Regenerate gemspec for version 1.0.4
authored Oct 18, 2011
44 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
261d23c @lautis Regenerate gemspec for version 0.5.2
authored May 12, 2011
45 s.add_runtime_dependency(%q<execjs>, [">= 0.3.0"])
dec4459 @lautis Regenerate gemspec for version 0.5.3
authored May 13, 2011
46 s.add_runtime_dependency(%q<multi_json>, [">= 1.0.2"])
a7e1bf9 @lautis Regenerate gemspec for version 1.1.0
authored Nov 15, 2011
47 s.add_development_dependency(%q<rspec>, ["~> 2.7"])
a358e5c @lautis Regenerate gemspec for version 1.2.0
authored Dec 15, 2011
48 s.add_development_dependency(%q<bundler>, ["~> 1.0"])
3763a3e @lautis Regenerate gemspec for version 1.0.0
authored Jun 21, 2011
49 s.add_development_dependency(%q<jeweler>, ["~> 1.6.0"])
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
50 s.add_development_dependency(%q<rcov>, [">= 0"])
a7e1bf9 @lautis Regenerate gemspec for version 1.1.0
authored Nov 15, 2011
51 s.add_development_dependency(%q<rdoc>, ["~> 3.11"])
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
52 else
261d23c @lautis Regenerate gemspec for version 0.5.2
authored May 12, 2011
53 s.add_dependency(%q<execjs>, [">= 0.3.0"])
dec4459 @lautis Regenerate gemspec for version 0.5.3
authored May 13, 2011
54 s.add_dependency(%q<multi_json>, [">= 1.0.2"])
a7e1bf9 @lautis Regenerate gemspec for version 1.1.0
authored Nov 15, 2011
55 s.add_dependency(%q<rspec>, ["~> 2.7"])
a358e5c @lautis Regenerate gemspec for version 1.2.0
authored Dec 15, 2011
56 s.add_dependency(%q<bundler>, ["~> 1.0"])
3763a3e @lautis Regenerate gemspec for version 1.0.0
authored Jun 21, 2011
57 s.add_dependency(%q<jeweler>, ["~> 1.6.0"])
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
58 s.add_dependency(%q<rcov>, [">= 0"])
a7e1bf9 @lautis Regenerate gemspec for version 1.1.0
authored Nov 15, 2011
59 s.add_dependency(%q<rdoc>, ["~> 3.11"])
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
60 end
61 else
261d23c @lautis Regenerate gemspec for version 0.5.2
authored May 12, 2011
62 s.add_dependency(%q<execjs>, [">= 0.3.0"])
dec4459 @lautis Regenerate gemspec for version 0.5.3
authored May 13, 2011
63 s.add_dependency(%q<multi_json>, [">= 1.0.2"])
a7e1bf9 @lautis Regenerate gemspec for version 1.1.0
authored Nov 15, 2011
64 s.add_dependency(%q<rspec>, ["~> 2.7"])
a358e5c @lautis Regenerate gemspec for version 1.2.0
authored Dec 15, 2011
65 s.add_dependency(%q<bundler>, ["~> 1.0"])
3763a3e @lautis Regenerate gemspec for version 1.0.0
authored Jun 21, 2011
66 s.add_dependency(%q<jeweler>, ["~> 1.6.0"])
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
67 s.add_dependency(%q<rcov>, [">= 0"])
a7e1bf9 @lautis Regenerate gemspec for version 1.1.0
authored Nov 15, 2011
68 s.add_dependency(%q<rdoc>, ["~> 3.11"])
a255b8f @lautis Regenerate gemspec for version 0.1.0
authored Nov 3, 2010
69 end
70 end
71
Something went wrong with that request. Please try again.