Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 33 lines (29 sloc) 1.159 kb
b2f51500 »
2013-10-26 Use bundler to manage gem release
1 # coding: utf-8
2 lib = File.expand_path('../lib', __FILE__)
3 $LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
4 require 'uglifier/version'
a255b8fd »
2010-11-03 Regenerate gemspec for version 0.1.0
5
b2f51500 »
2013-10-26 Use bundler to manage gem release
6 Gem::Specification.new do |spec|
7 spec.name = "uglifier"
8 spec.version = Uglifier::VERSION
9 spec.authors = ["Ville Lautanala"]
10 spec.email = ["lautis@gmail.com"]
11 spec.homepage = "http://github.com/lautis/uglifier"
12 spec.summary = "Ruby wrapper for UglifyJS JavaScript compressor"
13 spec.description = "Uglifier minifies JavaScript files by wrapping UglifyJS to be accessible in Ruby"
14 spec.license = "MIT"
a255b8fd »
2010-11-03 Regenerate gemspec for version 0.1.0
15
b2f51500 »
2013-10-26 Use bundler to manage gem release
16 spec.required_ruby_version = '>= 1.8.7'
17
18 spec.extra_rdoc_files = [
a255b8fd »
2010-11-03 Regenerate gemspec for version 0.1.0
19 "LICENSE.txt",
72f0c59e »
2012-03-27 Regenerate gemspec for version 1.2.4
20 "README.md"
a255b8fd »
2010-11-03 Regenerate gemspec for version 0.1.0
21 ]
b2f51500 »
2013-10-26 Use bundler to manage gem release
22 spec.files = `git ls-files`.split($/)
23 spec.test_files = spec.files.grep(%r{^spec/})
24 spec.require_paths = ["lib"]
a255b8fd »
2010-11-03 Regenerate gemspec for version 0.1.0
25
b2f51500 »
2013-10-26 Use bundler to manage gem release
26 spec.add_runtime_dependency "execjs", ">= 0.3.0"
27 spec.add_runtime_dependency "json", ">= 1.8.0"
365d6fdf »
2014-06-10 Use RSpec 3.0
28 spec.add_development_dependency "rspec", "~> 3.0"
d225220a »
2014-05-17 Update rake dependency requirement
29 spec.add_development_dependency "rake", "~> 10.3.0"
f9a18ba2 »
2013-10-26 Remove jeweler from gemspec
30 spec.add_development_dependency "bundler", "~> 1.3"
b2f51500 »
2013-10-26 Use bundler to manage gem release
31 spec.add_development_dependency "rdoc", ">= 3.11"
32 spec.add_development_dependency "source_map", ">= 0"
a255b8fd »
2010-11-03 Regenerate gemspec for version 0.1.0
33 end
Something went wrong with that request. Please try again.