Permalink
Browse files

Remove mtime check on fibers require()

If there are problems with the build, they aren't going to be from
upgrading Node. Plus I want to move to binary distribution soon if
possible and this will be counterproductive.
  • Loading branch information...
1 parent 5158112 commit 46595cc5b8718c910001cf955042afa8c6552391 @laverdet committed May 4, 2012
Showing with 0 additions and 9 deletions.
  1. +0 −9 fibers.js
View
@@ -1,13 +1,4 @@
var fs = require('fs'), path = require('path');
-if (fs.statSync(process.execPath).mtime >
- fs.statSync(require.resolve('./src/fibers')).mtime) {
- throw new Error(
- '`node` has a newer mtime than `fiber`; it is possible your build is out of date. This ' +
- 'could happen if you upgrade node. Try `npm rebuild fibers` to rebuild. If that doesn\'t ' +
- 'work you could consider running `touch ' + __dirname + 'src/fibers` and maybe there won\'t ' +
- 'be a problem.');
-}
-
// Injects `Fiber` and `yield` in to global
require('./src/fibers');

0 comments on commit 46595cc

Please sign in to comment.