Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 151 lines (147 sloc) 5.85 kb
89f8953c »
2009-04-09 Adding gemspec for github.
1 # -*- encoding: utf-8 -*-
2
3 Gem::Specification.new do |s|
4 s.name = %q{vanilla}
692d8a7f »
2011-05-03 Bumping version; now with upgrades.
5 s.version = "1.16.1"
89f8953c »
2009-04-09 Adding gemspec for github.
6
a8671f33 »
2011-04-28 Going to 1.15.
7 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
89f8953c »
2009-04-09 Adding gemspec for github.
8 s.authors = ["James Adam"]
991175fe »
2011-05-04 Opt in to gem test.
9 s.date = %q{2011-05-04}
89f8953c »
2009-04-09 Adding gemspec for github.
10 s.default_executable = %q{vanilla}
11 s.email = %q{james@lazyatom.com.com}
12 s.executables = ["vanilla"]
7fd835a7 »
2010-11-18 Released version 1.12.0
13 s.extra_rdoc_files = [
14 "README"
15 ]
16 s.files = [
17 "Rakefile",
18 "README",
991175fe »
2011-05-04 Opt in to gem test.
19 ".gemtest",
7fd835a7 »
2010-11-18 Released version 1.12.0
20 "lib/vanilla/app.rb",
21 "lib/vanilla/console.rb",
22 "lib/vanilla/dynasnip.rb",
23 "lib/vanilla/renderers/base.rb",
24 "lib/vanilla/renderers/bold.rb",
25 "lib/vanilla/renderers/erb.rb",
26 "lib/vanilla/renderers/haml.rb",
27 "lib/vanilla/renderers/markdown.rb",
28 "lib/vanilla/renderers/raw.rb",
29 "lib/vanilla/renderers/ruby.rb",
30 "lib/vanilla/renderers/textile.rb",
4e9da0ea »
2011-04-26 Bumping version.
31 "lib/vanilla/renderers.rb",
7fd835a7 »
2010-11-18 Released version 1.12.0
32 "lib/vanilla/request.rb",
33 "lib/vanilla/routes.rb",
34 "lib/vanilla/snip_reference_parser.rb",
35 "lib/vanilla/static.rb",
36 "lib/vanilla.rb",
37 "bin/vanilla",
0f2b6923 »
2011-04-28 Massive cleanup of the default application.
38 "pristine_app/config.ru",
39 "pristine_app/Gemfile",
f258f67a »
2011-04-28 Point new users at the tutorial.
40 "pristine_app/Gemfile.lock",
55a2b877 »
2011-04-28 Adding the simple styling to the gem.
41 "pristine_app/public/vanilla.css",
0f2b6923 »
2011-04-28 Massive cleanup of the default application.
42 "pristine_app/README",
eb742b4d »
2011-04-28 More tutorial, and fixing of dynasnips from extras.
43 "pristine_app/soups/base/layout.snip",
0f2b6923 »
2011-04-28 Massive cleanup of the default application.
44 "pristine_app/soups/base/start.snip",
45 "pristine_app/soups/extras/comments.rb",
46 "pristine_app/soups/extras/kind.rb",
47 "pristine_app/soups/extras/rand.rb",
48 "pristine_app/soups/extras/url_to.rb",
692d8a7f »
2011-05-03 Bumping version; now with upgrades.
49 "pristine_app/soups/system/current_snip.rb",
50 "pristine_app/soups/system/debug.rb",
51 "pristine_app/soups/system/index.rb",
52 "pristine_app/soups/system/link_to.rb",
53 "pristine_app/soups/system/link_to_current_snip.rb",
54 "pristine_app/soups/system/page_title.rb",
55 "pristine_app/soups/system/pre.rb",
56 "pristine_app/soups/system/raw.rb",
0f2b6923 »
2011-04-28 Massive cleanup of the default application.
57 "pristine_app/soups/tutorial/bad_dynasnip.snip",
58 "pristine_app/soups/tutorial/hello_world.snip",
59 "pristine_app/soups/tutorial/markdown_example.snip",
60 "pristine_app/soups/tutorial/snip.snip",
61 "pristine_app/soups/tutorial/soup.snip",
62 "pristine_app/soups/tutorial/test.snip",
63 "pristine_app/soups/tutorial/textile_example.snip",
64 "pristine_app/soups/tutorial/tutorial-another-snip.snip",
65 "pristine_app/soups/tutorial/tutorial-basic-snip-inclusion.snip",
eb742b4d »
2011-04-28 More tutorial, and fixing of dynasnips from extras.
66 "pristine_app/soups/tutorial/tutorial-dynasnips.snip.markdown",
67 "pristine_app/soups/tutorial/tutorial-layout.snip",
68 "pristine_app/soups/tutorial/tutorial-links.snip",
69 "pristine_app/soups/tutorial/tutorial-renderers.snip.markdown",
f258f67a »
2011-04-28 Point new users at the tutorial.
70 "pristine_app/soups/tutorial/tutorial.snip.markdown",
0f2b6923 »
2011-04-28 Massive cleanup of the default application.
71 "pristine_app/soups/tutorial/vanilla-rb.snip",
692d8a7f »
2011-05-03 Bumping version; now with upgrades.
72 "pristine_app/soups/tutorial/vanilla.snip",
991175fe »
2011-05-04 Opt in to gem test.
73 "pristine_app/tmp/restart.txt",
74 "test/dynasnip_test.rb",
75 "test/dynasnips/link_to_current_snip_test.rb",
76 "test/dynasnips/link_to_test.rb",
77 "test/dynasnips/page_title_test.rb",
78 "test/renderers/base_renderer_test.rb",
79 "test/renderers/erb_renderer_test.rb",
80 "test/renderers/haml_renderer_test.rb",
81 "test/renderers/markdown_renderer_test.rb",
82 "test/renderers/raw_renderer_test.rb",
83 "test/renderers/ruby_renderer_test.rb",
84 "test/snip_inclusion_test.rb",
85 "test/snip_reference_parser_test.rb",
86 "test/test_helper.rb",
87 "test/vanilla_app_test.rb",
88 "test/vanilla_presenting_test.rb",
89 "test/vanilla_request_test.rb"
7fd835a7 »
2010-11-18 Released version 1.12.0
90 ]
89f8953c »
2009-04-09 Adding gemspec for github.
91 s.homepage = %q{http://github.com/lazyatom/vanilla-rb}
92 s.rdoc_options = ["--main", "README"]
93 s.require_paths = ["lib"]
94 s.rubyforge_project = %q{vanilla}
991175fe »
2011-05-04 Opt in to gem test.
95 s.rubygems_version = %q{1.5.0}
89f8953c »
2009-04-09 Adding gemspec for github.
96 s.summary = %q{A bliki-type web content thing.}
991175fe »
2011-05-04 Opt in to gem test.
97 s.test_files = [
98 "test/dynasnip_test.rb",
99 "test/dynasnips/link_to_current_snip_test.rb",
100 "test/dynasnips/link_to_test.rb",
101 "test/dynasnips/page_title_test.rb",
102 "test/renderers/base_renderer_test.rb",
103 "test/renderers/erb_renderer_test.rb",
104 "test/renderers/haml_renderer_test.rb",
105 "test/renderers/markdown_renderer_test.rb",
106 "test/renderers/raw_renderer_test.rb",
107 "test/renderers/ruby_renderer_test.rb",
108 "test/snip_inclusion_test.rb",
109 "test/snip_reference_parser_test.rb",
110 "test/test_helper.rb",
111 "test/vanilla_app_test.rb",
112 "test/vanilla_presenting_test.rb",
113 "test/vanilla_request_test.rb"
114 ]
89f8953c »
2009-04-09 Adding gemspec for github.
115
116 if s.respond_to? :specification_version then
819bffff »
2009-08-26 Up version to 1.1.0
117 s.specification_version = 3
89f8953c »
2009-04-09 Adding gemspec for github.
118
fbcec57e »
2010-11-13 We don't use this backend anymore.
119 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
b309edc5 »
2009-04-09 Fixed the README to reflect the gemmification, and added the dependen…
120 s.add_runtime_dependency(%q<rack>, [">= 0.9.1"])
4263af57 »
2011-03-01 Use a fixed version of bundler; also update the console to use bundler.
121 s.add_runtime_dependency(%q<soup>, [">= 1.0.6"])
b309edc5 »
2009-04-09 Fixed the README to reflect the gemmification, and added the dependen…
122 s.add_runtime_dependency(%q<ratom>, [">= 0.3.5"])
123 s.add_runtime_dependency(%q<RedCloth>, [">= 4.1.1"])
124 s.add_runtime_dependency(%q<BlueCloth>, [">= 1.0.0"])
f8a259d9 »
2011-02-22 More simplifications and fixes to get the generated vanilla applicati…
125 s.add_runtime_dependency(%q<haml>, [">= 0"])
3850e99d »
2011-05-01 Testing out the parslet parser library.
126 s.add_runtime_dependency(%q<parslet>, [">= 1.2.0"])
24122b0c »
2011-05-01 Improve the coverage of the snip reference parsing test.
127 s.add_development_dependency(%q<kintama>, [">= 0.1.6"])
61cd607b »
2009-11-23 Swapped RSpec for test/unit, shoulda and mocha.
128 s.add_development_dependency(%q<mocha>, [">= 0"])
89f8953c »
2009-04-09 Adding gemspec for github.
129 else
b309edc5 »
2009-04-09 Fixed the README to reflect the gemmification, and added the dependen…
130 s.add_dependency(%q<rack>, [">= 0.9.1"])
4263af57 »
2011-03-01 Use a fixed version of bundler; also update the console to use bundler.
131 s.add_dependency(%q<soup>, [">= 1.0.6"])
b309edc5 »
2009-04-09 Fixed the README to reflect the gemmification, and added the dependen…
132 s.add_dependency(%q<ratom>, [">= 0.3.5"])
133 s.add_dependency(%q<RedCloth>, [">= 4.1.1"])
134 s.add_dependency(%q<BlueCloth>, [">= 1.0.0"])
f8a259d9 »
2011-02-22 More simplifications and fixes to get the generated vanilla applicati…
135 s.add_dependency(%q<haml>, [">= 0"])
3850e99d »
2011-05-01 Testing out the parslet parser library.
136 s.add_dependency(%q<parslet>, [">= 1.2.0"])
24122b0c »
2011-05-01 Improve the coverage of the snip reference parsing test.
137 s.add_dependency(%q<kintama>, [">= 0.1.6"])
61cd607b »
2009-11-23 Swapped RSpec for test/unit, shoulda and mocha.
138 s.add_dependency(%q<mocha>, [">= 0"])
89f8953c »
2009-04-09 Adding gemspec for github.
139 end
140 else
b309edc5 »
2009-04-09 Fixed the README to reflect the gemmification, and added the dependen…
141 s.add_dependency(%q<rack>, [">= 0.9.1"])
4263af57 »
2011-03-01 Use a fixed version of bundler; also update the console to use bundler.
142 s.add_dependency(%q<soup>, [">= 1.0.6"])
b309edc5 »
2009-04-09 Fixed the README to reflect the gemmification, and added the dependen…
143 s.add_dependency(%q<ratom>, [">= 0.3.5"])
144 s.add_dependency(%q<RedCloth>, [">= 4.1.1"])
145 s.add_dependency(%q<BlueCloth>, [">= 1.0.0"])
f8a259d9 »
2011-02-22 More simplifications and fixes to get the generated vanilla applicati…
146 s.add_dependency(%q<haml>, [">= 0"])
3850e99d »
2011-05-01 Testing out the parslet parser library.
147 s.add_dependency(%q<parslet>, [">= 1.2.0"])
24122b0c »
2011-05-01 Improve the coverage of the snip reference parsing test.
148 s.add_dependency(%q<kintama>, [">= 0.1.6"])
61cd607b »
2009-11-23 Swapped RSpec for test/unit, shoulda and mocha.
149 s.add_dependency(%q<mocha>, [">= 0"])
89f8953c »
2009-04-09 Adding gemspec for github.
150 end
151 end
Something went wrong with that request. Please try again.