Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

fixes file name errors

  • Loading branch information...
commit 8c243b1bd3875560acd087209fcb82f24d504db3 1 parent b9a9b96
@lazylester authored
View
1  Gemfile
@@ -1 +1,2 @@
+source 'https://rubygems.org'
gemspec
View
24 Gemfile.lock
@@ -1,3 +1,11 @@
+PATH
+ remote: .
+ specs:
+ damerau-levenshtein (1.0.1)
+ bundler (~> 1.0)
+ rake (~> 10.0)
+ rake-compiler (~> 0.8)
+
GEM
remote: https://rubygems.org/
specs:
@@ -23,23 +31,15 @@ GEM
diff-lcs (1.2.1)
gherkin (2.11.6)
json (>= 1.7.6)
- git (1.2.5)
i18n (0.6.4)
- jeweler (1.8.4)
- bundler (~> 1.0)
- git (>= 1.2.5)
- rake
- rdoc
json (1.7.7)
metaclass (0.0.1)
mocha (0.10.5)
metaclass (~> 0.0.1)
multi_json (1.6.1)
- rake (10.0.3)
+ rake (10.0.4)
rake-compiler (0.8.3)
rake
- rdoc (4.0.0)
- json (~> 1.4)
rspec (2.13.0)
rspec-core (~> 2.13.0)
rspec-expectations (~> 2.13.0)
@@ -65,13 +65,9 @@ PLATFORMS
ruby
DEPENDENCIES
- bundler (~> 1.0)
cucumber (~> 1.2)
+ damerau-levenshtein!
debugger (~> 1.4)
- jeweler (~> 1.8)
- mocha (~> 0.10)
- rake (~> 10.0)
- rake-compiler (~> 0.8)
rspec (~> 2.13)
ruby-prof (~> 0.13)
shoulda (~> 3.3)
View
20 Rakefile
@@ -13,26 +13,6 @@ require 'rake/dsl_definition'
require 'rake'
require 'rake/extensiontask'
-require 'jeweler'
-Jeweler::Tasks.new do |gem|
- # gem is a Gem::Specification...
- # see http://docs.rubygems.org/read/chapter/20 for more options
- gem.name = 'damerau-levenshtein'
- gem.homepage = 'http://github.com/GlobalNamesArchitecture/damerau-levenshtein'
- gem.license = 'MIT'
- gem.summary = %Q{Calculation of editing distance for 2 strings \
- using Levenshtein or Damerau-Levenshtein algorithms}
- gem.description = %Q{Calculation of editing distance for 2 strings using \
- Levenshtein or Damerau-Levenshtein algorithms}
- gem.email = 'dmozzherin@gmail.com'
- gem.authors = ['Dmitry Mozzherin']
- gem.files = FileList['[A-Z]*', '*.gemspec', '{bin,generators,lib,spec}/**/*']
- gem.files -= FileList['lib/**/*.bundle', 'lib/**/*.dll', 'lib/**/*.so']
- gem.files += FileList['ext/**/*.c']
- gem.extensions = FileList['ext/**/extconf.rb']
-end
-Jeweler::RubygemsDotOrgTasks.new
-
require 'rspec'
require 'rspec/core/rake_task'
RSpec::Core::RakeTask.new(:spec) do |spec|
View
3  lib/damerau-levenschtein/version.rb
@@ -1,3 +0,0 @@
-module DamerauLevenschtein
- VERSION = 1.0.1
-end
View
1  lib/damerau-levenshtein.rb
@@ -1,6 +1,7 @@
# encoding: UTF-8
require 'damerau_levenshtein_binding'
+require 'damerau-levenshtein/version'
module DamerauLevenshtein
extend DamerauLevenshteinBinding
View
3  lib/damerau-levenshtein/version.rb
@@ -0,0 +1,3 @@
+module DamerauLevenshtein
+ VERSION = '1.0.1'
+end
View
2  spec/damerau-levenshtein_spec.rb
@@ -3,7 +3,7 @@
describe DamerauLevenshtein do
it 'should return version' do
- DamerauLevenshtein.version.should =~ /^\d+\.\d+\.\d+$/
+ DamerauLevenshtein::VERSION.should =~ /^\d+\.\d+\.\d+$/
end
it 'should get tests' do
Please sign in to comment.
Something went wrong with that request. Please try again.