New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

UI glitch after accessing a video without enough credits #605

Closed
mirgee opened this Issue Sep 22, 2017 · 10 comments

Comments

Projects
None yet
4 participants
@mirgee

mirgee commented Sep 22, 2017

The Issue

A UI glitch (see screenshot below) appears after trying to play a searched video without enough credits.

Steps to reproduce

  1. Make sure you don't have much credits
  2. Search for a video
  3. Click on a search result you don't have enough credits for
  4. Try to play the video
  5. Click on Not now

Expected behaviour

Page of the video, like this:
screenshot from 2017-09-22 10-28-29

Actual behaviour

Black dot, like this:
screenshot from 2017-09-22 10-26-10

System Configuration

screenshot from 2017-09-22 15-03-37

{
"build": "dev",
"installation_id": "6QapiUUrkTfiks6jiQnecv8pXixxm1LncbgGB32x6nXpQ1aipjikPboVJM4UxsXruR",
"lbrynet_version": "0.16.1-2-g875d512",
"lbryschema_version": "0.0.11rc1",
"lbryum_version": "3.1.7rc5",
"os_release": "4.10.0-35-generic",
"os_system": "Linux",
"platform": "Linux-4.10.0-35-generic-x86_64-with-Ubuntu-16.04-xenial",
"processor": "x86_64",
"python_version": "2.7.12"
}

Anything Else

This doesn't happen to a video accessed or accessible from feature page, only to other videos found through search.

@tzarebczan

This comment has been minimized.

Show comment
Hide comment
@tzarebczan

tzarebczan Sep 22, 2017

Member

So the video spins and the play button disappears? I'll try to reproduce later.

Anything in the console or network logs?

Member

tzarebczan commented Sep 22, 2017

So the video spins and the play button disappears? I'll try to reproduce later.

Anything in the console or network logs?

@mirgee

This comment has been minimized.

Show comment
Hide comment
@mirgee

mirgee Sep 22, 2017

@tzarebczan The screenshot didn't upload for some reason, hope it's better now. Spinning and play button disappearing is what happens on videos through featured. This is probably intended and acceptable. The actual behavior after search is not.

mirgee commented Sep 22, 2017

@tzarebczan The screenshot didn't upload for some reason, hope it's better now. Spinning and play button disappearing is what happens on videos through featured. This is probably intended and acceptable. The actual behavior after search is not.

@btzr-io btzr-io referenced this issue Sep 25, 2017

Merged

Minor redesign #612

9 of 9 tasks complete

@btzr-io btzr-io added the area: ux label Sep 26, 2017

btzr-io added a commit that referenced this issue Sep 26, 2017

btzr-io added a commit that referenced this issue Sep 26, 2017

@btzr-io btzr-io removed the css label Sep 26, 2017

@tzarebczan

This comment has been minimized.

Show comment
Hide comment
@tzarebczan

tzarebczan Sep 27, 2017

Member

@btzr-io thanks for looking at this. Did you get it to stop spinning in the case of not enough funds too?

Member

tzarebczan commented Sep 27, 2017

@btzr-io thanks for looking at this. Did you get it to stop spinning in the case of not enough funds too?

@btzr-io btzr-io added this to the Redesign milestone Sep 29, 2017

@btzr-io

This comment has been minimized.

Show comment
Hide comment
@btzr-io

btzr-io Sep 29, 2017

Collaborator

@tzarebczan nope, not a css bug,
I guess the video component needs refactoring,
also It shouldn't show the player instead an empty state or something else...

This was my initial idea but I hope someone make something better 😛

Collaborator

btzr-io commented Sep 29, 2017

@tzarebczan nope, not a css bug,
I guess the video component needs refactoring,
also It shouldn't show the player instead an empty state or something else...

This was my initial idea but I hope someone make something better 😛

@btzr-io btzr-io modified the milestones: Redesign, October 2 Oct 1, 2017

@btzr-io btzr-io referenced this issue Oct 1, 2017

Merged

Fix issues with playing uri #642

1 of 1 task complete
@btzr-io

This comment has been minimized.

Show comment
Hide comment
@btzr-io

btzr-io Oct 1, 2017

Collaborator

@mirgee could you provide the link of the video ?
you can also test this branch: https://github.com/lbryio/lbry-app/tree/fix-play

Collaborator

btzr-io commented Oct 1, 2017

@mirgee could you provide the link of the video ?
you can also test this branch: https://github.com/lbryio/lbry-app/tree/fix-play

@btzr-io

This comment has been minimized.

Show comment
Hide comment
@btzr-io

btzr-io Oct 1, 2017

Collaborator

@tzarebczan I'm not able to recreate the background glitch,
but I was able to stop the spinning ^^

Collaborator

btzr-io commented Oct 1, 2017

@tzarebczan I'm not able to recreate the background glitch,
but I was able to stop the spinning ^^

@MSFTserver

This comment has been minimized.

Show comment
Hide comment
@MSFTserver

MSFTserver Oct 1, 2017

Contributor

@btzr-io i noticed this also happens when videos fail to download you could try some videos you know wont work

Contributor

MSFTserver commented Oct 1, 2017

@btzr-io i noticed this also happens when videos fail to download you could try some videos you know wont work

@btzr-io

This comment has been minimized.

Show comment
Hide comment
@btzr-io

btzr-io Oct 1, 2017

Collaborator

@MSFTserver Do you have any example ( link ) to test it ?

Collaborator

btzr-io commented Oct 1, 2017

@MSFTserver Do you have any example ( link ) to test it ?

@btzr-io

This comment has been minimized.

Show comment
Hide comment
@btzr-io

btzr-io Oct 1, 2017

Collaborator

@tzarebczan the UI glitch isn't limited to videos and looks like is a different issue...

Collaborator

btzr-io commented Oct 1, 2017

@tzarebczan the UI glitch isn't limited to videos and looks like is a different issue...

@kauffj kauffj closed this in 449997f Oct 1, 2017

@btzr-io btzr-io referenced this issue Oct 2, 2017

Merged

Minor redesign (css) #647

18 of 21 tasks complete
@tzarebczan

This comment has been minimized.

Show comment
Hide comment
@tzarebczan

tzarebczan Oct 11, 2017

Member

@mirgee - please take a look at https://lbry.io/faq/tips :)

Member

tzarebczan commented Oct 11, 2017

@mirgee - please take a look at https://lbry.io/faq/tips :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment