Skip to content
Fetching contributors…
Cannot retrieve contributors at this time
29 lines (27 sloc) 676 Bytes
language: cpp
install:
- sudo apt-get update -qq
# The Ubuntu 12.04 repos only have LLVM 3.0, should find a 3.1 PPA.
- sudo apt-get install -qq llvm-3.0-dev libconfig++8-dev
env:
- DVER=1
- DVER=2
before_script:
- git submodule update --init --recursive
script:
- cmake -DD_VERSION=$DVER -DLLVM_CONFIG=/usr/bin/llvm-config-3.0
- make
- make test || { cat Testing/Temporary/LastTest.log; exit 1; }
notifications:
email:
recipients:
- "ldc-dev@googlegroups.com"
on_success: never
on_failure: change
irc:
channels:
- "irc.freenode.org#ldc"
on_success: always
on_failure: always
use_notice: false
skip_join: true
Something went wrong with that request. Please try again.