Permalink
Browse files

Declared all the oCV needed dependencies.

  • Loading branch information...
ldemattos committed Mar 8, 2017
1 parent 8f01d7e commit 2f21ccc879aed979d685c2c9299f3162f7e0c37b
Showing with 8 additions and 4 deletions.
  1. +5 −0 README.md
  2. +3 −4 setup.py
@@ -4,12 +4,17 @@ An open/free multi platform IEEE COMTRADE oscillograph records visualizer and da

It's have been successfully tested in GNU/Linux, Microsoft Windows 7 and Mac OS X.


## General Install Guidance

The openComtradeViewer is developed with Python language, version 2.7. Therefore, to properly run it will be necessary to have the Python interpreter installed on your computer. Nevertheless, some non-standard libraries will be needed as well. If you run GNU/Linux, Mac OS X or other unix-flavor operating system you probably have Python interpreter installed. However, if you use Microsoft Windows there is a great chance that you will need to [install the interpreter by yourself](https://www.python.org/downloads/).

The installation of openComtradeViewer and its dependecies is simple in all OSs and can be performed with the simple command line below:
```
pip install https://github.com/ldemattos/openComtradeViewer/archive/master.zip --user
```
To upgrade openComtradeViewer only needs the following command:
```
pip install https://github.com/ldemattos/openComtradeViewer/archive/master.zip --user --upgrade
```

@@ -38,10 +38,9 @@
url='https://github.com/ldemattos/openComtradeViewer',
packages=['openComtradeViewer'],
install_requires=[
'Tkinter',
'matplotlib',
'scipy',
'numpy',
'matplotlib>=1.5.1',
'scipy>=0.18.0',
'numpy>=1.11.0',
],
package_dir={'openComtradeViewer':'src'},
entry_points = {

0 comments on commit 2f21ccc

Please sign in to comment.