Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

1.12.2 you need to be close to your town hall #2249

Closed
Faenum opened this issue Feb 21, 2018 · 32 comments

Comments

@Faenum
Copy link

commented Feb 21, 2018

Minecolonies version

version 0.8.7608

Expected behavior

To be able to build a builders hut right next to the town hall

Actual behaviour

You need to be closer to your town hall message, i cant build a town hall without a builder, but i cant build a builder because of this.

Steps to reproduce the issue

Place town hall, try to place builders hut

@Raycoms

This comment has been minimized.

Copy link
Contributor

commented Feb 21, 2018

@Faenum

This comment has been minimized.

Copy link
Author

commented Feb 21, 2018

I'm not familiar with how to send it as a gist, never done it before.

@Raycoms

This comment has been minimized.

Copy link
Contributor

commented Feb 21, 2018

@Faenum

This comment has been minimized.

Copy link
Author

commented Feb 21, 2018

@Raycoms

This comment has been minimized.

Copy link
Contributor

commented Feb 21, 2018

@Faenum

This comment has been minimized.

Copy link
Author

commented Feb 21, 2018

ive found this if its helpful#
[17:43:22] [Server thread/INFO]: chunk has colonies: []
[17:43:33] [Server thread/INFO]: chunk has colonies: []
[17:43:35] [Server thread/INFO]: chunk has colonies: []
[17:44:05] [Server thread/INFO]: chunk has colonies: []
[17:44:08] [Server thread/INFO]: chunk has colonies: []
[17:44:13] [Server thread/INFO]: chunk has colonies: []
[17:44:14] [Server thread/INFO]: chunk has colonies: []
[17:44:18] [Server thread/INFO]: chunk has colonies: []
[17:44:18] [Server thread/INFO]: chunk has colonies: []

@DjTylerD

This comment has been minimized.

Copy link

commented Feb 21, 2018

hello Faenum was faster than me, the time to retest on a new solo map.
all huts can be built on the chunk of the block townhall.
i try to change the new townHallPaddingChunk configuration, but it changes nothing.
return to minecolonies-universal-1.12.2-0.8.7594 the bug disappeared

Minecolonies version:
minecolonies-universal-1.12.2-0.8.7608
forge1.12.2-14.23.1.2555
OptiFine_1.12.2_HD_U_C8
no other mod

map test creative solo
/ mc colonies rsResetAll at every update

@Raycoms

This comment has been minimized.

Copy link
Contributor

commented Feb 21, 2018

@Faenum

This comment has been minimized.

Copy link
Author

commented Feb 21, 2018

this is a new map im trying to use it on, in single player, ive tried putting down a couple of buildings right next to the town hall and its giving me that error.
there are several files in my chunkinfo folder

@Raycoms

This comment has been minimized.

Copy link
Contributor

commented Feb 21, 2018

@Raycoms

This comment has been minimized.

Copy link
Contributor

commented Feb 21, 2018

@Faenum

This comment has been minimized.

Copy link
Author

commented Feb 21, 2018

yep, windows 10.

@Faenum

This comment has been minimized.

Copy link
Author

commented Feb 21, 2018

sweet thanks

@DjTylerD

This comment has been minimized.

Copy link

commented Feb 21, 2018

minecolonies-universal-1.12.2-0.8.7611.jar
always the same problem
in save / test mine / minecolonies / chunkInfo
I have 35 files from -0 to -27 all empty and without extension (.txt or .dat, ect ...)

@Faenum

This comment has been minimized.

Copy link
Author

commented Feb 21, 2018

What version number will that be please?

@Raycoms

This comment has been minimized.

Copy link
Contributor

commented Feb 21, 2018

@Faenum

This comment has been minimized.

Copy link
Author

commented Feb 21, 2018

Ive updated and still getting the same issue, do i need to start a new world for it to work?

@Faenum

This comment has been minimized.

Copy link
Author

commented Feb 21, 2018

Tried it on a new map, still got the same problem

@Raycoms

This comment has been minimized.

Copy link
Contributor

commented Feb 21, 2018

@Faenum

This comment has been minimized.

Copy link
Author

commented Feb 21, 2018

Ok thanks

@Faenum

This comment has been minimized.

Copy link
Author

commented Feb 21, 2018

Still not working, getting same issue.

@Raycoms

This comment has been minimized.

Copy link
Contributor

commented Feb 21, 2018

@DjTylerD

This comment has been minimized.

Copy link

commented Feb 21, 2018

note 7613
still same problem, but on a new map it works thanks to the name change of chunk-0 to chunk-0_0_0 folder

on my game map i try / mc colonies rsResetAll or clear the files i games not trying to rewrite files

@Raycoms

This comment has been minimized.

Copy link
Contributor

commented Feb 21, 2018

@Faenum

This comment has been minimized.

Copy link
Author

commented Feb 21, 2018

Ok its working in a new world.

@DjTylerD

This comment has been minimized.

Copy link

commented Feb 21, 2018

@Raycoms
the problem has become chunk file, on the new map, there is chunk-0_1_0, chunk-1_0_0 ect ....
just to load map, ask townhall and try hut builder
I have 1089 files (I miss it)

@Raycoms

This comment has been minimized.

Copy link
Contributor

commented Feb 21, 2018

@DjTylerD

This comment has been minimized.

Copy link

commented Feb 21, 2018

@Raycoms I will test
but good for me it's not serious what are the test maps
to help you because I'm thinking about the other player
(I have my server in stanbye since minecraft 1.11.2, following all the modif commandblock 1.12 and soon 1.13)

@Raycoms

This comment has been minimized.

Copy link
Contributor

commented Feb 21, 2018

@DjTylerD

This comment has been minimized.

Copy link

commented Feb 21, 2018

lol, I did not know the news
/ mc colony delete 1 destroyed all buildings

@Raycoms

This comment has been minimized.

Copy link
Contributor

commented Feb 21, 2018

@DjTylerD

This comment has been minimized.

Copy link

commented Feb 21, 2018

good test finished, my last save map date 19-02
so without going through the day's bug
with my save no bug and I have no file in chunkinfo

@Raycoms Raycoms closed this Feb 22, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.