New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

只能用localhost访问,不能用ip或域名访问 #709

Closed
nonesuccess243 opened this Issue Dec 23, 2017 · 5 comments

Comments

Projects
None yet
6 participants
@nonesuccess243

nonesuccess243 commented Dec 23, 2017

服务器环境为centos 7

修改app.conf中的site.url,将localhost改为ip或者域名,再启动run.sh的时候,debug信息都显示Listening on., localhost:9000。

在本地wget localhost:9000 正常,wget ip:9090,显示connection refused。

在外网访问ip:9000,拒绝连接

防火墙已经打开了9000端口,将防火墙整体关闭后,效果不变。

在app.conf文件中将端口号随便改成其它端口,再启动,debug信息显示Listening on., localhost:9009,证明没有找错文件。

请问这是怎么回事

@hanwangkun

This comment has been minimized.

Show comment
Hide comment
@hanwangkun

hanwangkun Dec 25, 2017

只能通过增加nginx作为反向代理来进行远程访问

hanwangkun commented Dec 25, 2017

只能通过增加nginx作为反向代理来进行远程访问

@vector090

This comment has been minimized.

Show comment
Hide comment
@vector090

vector090 Jan 11, 2018

设置 http.addr=所需IP 即可

vector090 commented Jan 11, 2018

设置 http.addr=所需IP 即可

@JerryJiangjjw

This comment has been minimized.

Show comment
Hide comment
@JerryJiangjjw

JerryJiangjjw Jan 18, 2018

server {
listen 9001 ;
location / {
proxy_pass http://127.0.0.1:9000;
}
}
我是通过配置nginx解决

JerryJiangjjw commented Jan 18, 2018

server {
listen 9001 ;
location / {
proxy_pass http://127.0.0.1:9000;
}
}
我是通过配置nginx解决

@oldFuryBird

This comment has been minimized.

Show comment
Hide comment
@oldFuryBird

oldFuryBird Jan 18, 2018

注意 : leanote 的http.addr 藏在下面 离http.port很远,
修改 http.addr=0.0.0.0

oldFuryBird commented Jan 18, 2018

注意 : leanote 的http.addr 藏在下面 离http.port很远,
修改 http.addr=0.0.0.0

@lealife lealife closed this Mar 8, 2018

@lealife

This comment has been minimized.

Show comment
Hide comment
@lealife

lealife Mar 8, 2018

Member

Can you try to set http.addr=0.0.0.0 in conf/app.conf and see if it fixes it for you?

Member

lealife commented Mar 8, 2018

Can you try to set http.addr=0.0.0.0 in conf/app.conf and see if it fixes it for you?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment