Skip to content
Leap Motion SDK for Unity.
C# Other
  1. C# 98.3%
  2. Other 1.7%
Branch: develop
Clone or download

README.md

Leap Motion Unity Modules

To download Leap Motion's latest stable modules as .unitypackages, visit our Unity developer site. Be sure to also check out our documentation and API reference!

UnityModules packages from our developer website support Unity 5.6.2, 2017.1-4, and 2018.1. Newer versions of Unity are usually perfectly safe to use. If you encounter errors or warnings with newer Unity versions, please report them as an Issue.

Since Unity Modules 4.5.0, our releases page on this repository is the official source for distribution. This version of UnityModules fixes compilation warnings in Unity 2019 and includes some fixes for newer Unity features like the Scriptable Render Pipeline (in 2019.1 and beyond).

The UnityModules repository expects Unity 2017.3 and up. If you are sourcing UnityModules directly from this repository, your mileage may vary with earlier versions of Unity.

License

Use of Leap Motion's UnityModules is subject to the Leap Motion developer SDK agreement.

This repository

This repository contains code for Leap Motion's Unity Modules, easy-to-use tools for integrating the Leap Motion Controller in Unity projects, and various utilities for VR and AR projects.

Note that this repository also contains code for work-in-progress modules, tentative modules, or older modules that may be unsupported. We recommend using the packages available on the developer site unless you're planning on contributing or you are otherwise feeling particularly hardcore.

You can’t perform that action at this time.