New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Where is my orange dot??? #5036

Closed
radinamatic opened this Issue Mar 24, 2016 · 10 comments

Comments

Projects
None yet
6 participants
@radinamatic
Contributor

radinamatic commented Mar 24, 2016

Summary

/learn/khan/math/arithmetic/multiplication-division/multiplication_fun/number_line/ exercise is missing the essential orange dot. Compare with screenshots from @rtibbles #4981.
Woff2 font problem?

Branch or installer method

Upgrade scenario on OSX Yosemite from 0.15 to 0.16 with .pkg build 99.

Traceback or relevant snippet from server.log

Usual WOFF2 font missing errors in the console

How to reproduce

  1. Login as Learner.
  2. Navigate to /learn/khan/math/arithmetic/multiplication-division/multiplication_fun/number_line/
  3. Observe.

Screenshots

On Firefox:

where-is-my-orange-dot-ff

On Chrome

where-is-my-orange-dot-chrome

Real-life consequences

Exercise cannot be completed.

@66eli77

This comment has been minimized.

Show comment
Hide comment
@66eli77

66eli77 Mar 24, 2016

Contributor

I can confirm the same issue, missing orange dot, on Mac 0.16.x

Contributor

66eli77 commented Mar 24, 2016

I can confirm the same issue, missing orange dot, on Mac 0.16.x

@radinamatic

This comment has been minimized.

Show comment
Hide comment
@radinamatic

radinamatic Mar 24, 2016

Contributor

Confirmed on Beta3 deb installer on Ubuntu 15.10:

missing-orange-dot

I can't even figure out what is supposed to render the dot... The only two 404s are the infamous WOFF2 fonts... 😒

Contributor

radinamatic commented Mar 24, 2016

Confirmed on Beta3 deb installer on Ubuntu 15.10:

missing-orange-dot

I can't even figure out what is supposed to render the dot... The only two 404s are the infamous WOFF2 fonts... 😒

@jamalex

This comment has been minimized.

Show comment
Hide comment
@jamalex

jamalex Apr 12, 2016

Member

Fly-by diagnosis:

It looks like KA is now using Perseus for https://www.khanacademy.org/math/arithmetic/absolute-value/add-sub-negatives/e/number_line_2, whereas we're still using an old khan-exercises version (http://127.0.0.1:8008/api/content/khan/number_line_2/)? Very strange. Same was true of 0.15, but the dot worked back then (http://demo.learningequality.org/learn/khan/math/pre-algebra/negatives-absolute-value-pre-alg/add-sub-negatives-pre-alg/number_line_2/). Any sense of why we might be preferring khan-exercises over Perseus versions, @rtibbles or @aronasorman?

Member

jamalex commented Apr 12, 2016

Fly-by diagnosis:

It looks like KA is now using Perseus for https://www.khanacademy.org/math/arithmetic/absolute-value/add-sub-negatives/e/number_line_2, whereas we're still using an old khan-exercises version (http://127.0.0.1:8008/api/content/khan/number_line_2/)? Very strange. Same was true of 0.15, but the dot worked back then (http://demo.learningequality.org/learn/khan/math/pre-algebra/negatives-absolute-value-pre-alg/add-sub-negatives-pre-alg/number_line_2/). Any sense of why we might be preferring khan-exercises over Perseus versions, @rtibbles or @aronasorman?

@radinamatic

This comment has been minimized.

Show comment
Hide comment
@radinamatic

radinamatic Apr 12, 2016

Contributor

Compare with screenshots from @rtibbles' issue #4981.

Orange dot seems to have disappeared at some point between March 10 and 24.

Contributor

radinamatic commented Apr 12, 2016

Compare with screenshots from @rtibbles' issue #4981.

Orange dot seems to have disappeared at some point between March 10 and 24.

@harishbalachandran

This comment has been minimized.

Show comment
Hide comment
@harishbalachandran

harishbalachandran Apr 21, 2016

Facing the same problem on following Installer method:
OS: Ubuntu version 14 LTS
Installer: "pip install ka-lite" and "sudo kalite manage setup"
Version: 0.16.1
assessment file: en.zip (697.1 MB)

Note:
This problem is universal across all the exercises that has number line with orange dot.

Screen shots:
screenshot from 2016-04-21 09_35_44

screenshot from 2016-04-21 12_56_36

harishbalachandran commented Apr 21, 2016

Facing the same problem on following Installer method:
OS: Ubuntu version 14 LTS
Installer: "pip install ka-lite" and "sudo kalite manage setup"
Version: 0.16.1
assessment file: en.zip (697.1 MB)

Note:
This problem is universal across all the exercises that has number line with orange dot.

Screen shots:
screenshot from 2016-04-21 09_35_44

screenshot from 2016-04-21 12_56_36

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming Apr 27, 2016

Member

Confirmed fixed in #5105

screenshot from 2016-04-27 14 30 07

Member

benjaoming commented Apr 27, 2016

Confirmed fixed in #5105

screenshot from 2016-04-27 14 30 07

@benjaoming benjaoming closed this Apr 27, 2016

@benjaoming benjaoming removed the has PR label Apr 27, 2016

@radinamatic

This comment has been minimized.

Show comment
Hide comment
@radinamatic

radinamatic May 5, 2016

Contributor

@benjaoming I'm not seeing the infamous orange dot, but Invalid number line configuration error in this exercise:
(0.16.5 on Ubuntu 16.04)

ubuntu16 ready running - oracle vm virtualbox_438

Contributor

radinamatic commented May 5, 2016

@benjaoming I'm not seeing the infamous orange dot, but Invalid number line configuration error in this exercise:
(0.16.5 on Ubuntu 16.04)

ubuntu16 ready running - oracle vm virtualbox_438

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming May 6, 2016

Member

That sounds very strange, I have it running fine on 14.04 -- having everything up and running and facing a problem in a browser is hardly related to the platform. Could you try the same exercise in English?

(btw. I have it working perfectly, 0.16.5 install from ka-lite-bundle deb, clean install on 14.04)

Member

benjaoming commented May 6, 2016

That sounds very strange, I have it running fine on 14.04 -- having everything up and running and facing a problem in a browser is hardly related to the platform. Could you try the same exercise in English?

(btw. I have it working perfectly, 0.16.5 install from ka-lite-bundle deb, clean install on 14.04)

@radinamatic

This comment has been minimized.

Show comment
Hide comment
@radinamatic

radinamatic May 6, 2016

Contributor

Good intuition... 👍
Dot is there when UI is in English, but error appears on both Spanish and Portuguese:

ubuntu16 ready running - oracle vm virtualbox_439

Contributor

radinamatic commented May 6, 2016

Good intuition... 👍
Dot is there when UI is in English, but error appears on both Spanish and Portuguese:

ubuntu16 ready running - oracle vm virtualbox_439

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming May 6, 2016

Member

@rtibbles did we dig up another possibly critical problem with translations - possibly related to #5107 ?

@radinamatic could you start a new issue report regarding this specific problem? It's difficult for others to understand what's going on from deep down an old issue about something else :) (although seemingly related, the above issue was fixed and the nature of this problem is a different one)

Member

benjaoming commented May 6, 2016

@rtibbles did we dig up another possibly critical problem with translations - possibly related to #5107 ?

@radinamatic could you start a new issue report regarding this specific problem? It's difficult for others to understand what's going on from deep down an old issue about something else :) (although seemingly related, the above issue was fixed and the nature of this problem is a different one)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment