New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Activating simplified login results in blank login modal #5255

Closed
Aypak opened this Issue Aug 8, 2016 · 4 comments

Comments

Projects
None yet
4 participants
@Aypak
Contributor

Aypak commented Aug 8, 2016

Summary

Simplified login is a feature that is supposed to allow users to login with username only. However, when this feature is activated, it produces a blank login modal and the error Uncaught ReferenceError: setGetParamDict is not defined in the console. This issue was previously closed in #3553 but seems to have resurfaced. It is not clear in which release of kalite it first re-emerged.

System information

  • Operating system: Ubuntu 16.04
  • Version: 0.16.8
  • Browser: Chrome

How to reproduce

  1. Add SIMPLIFIED_LOGIN = True to settings.py
  2. Restart kalite server
  3. Attempt to log in

Screenshots

untitled

Real-life consequences

When using kalite with very young learners, they often forget their passwords. It is easier to have them type in their username only in order to login. This will save alot of time and frustration for the young ones.
Thanks!

@Aypak

This comment has been minimized.

Show comment
Hide comment
@Aypak

Aypak Sep 28, 2016

Contributor

Hi Everybody, I hope i'm not too late to the party. Thanks for all your effort in resolving this. However, i noticed that admins and coaches were not able to login if LOCKDOWN is also activated
screenshot at 2016-09-28 14-33-34

I created a PR to fix this - #5297. Now it works perfectly when lockdown is also activated.
Thanks again!

Contributor

Aypak commented Sep 28, 2016

Hi Everybody, I hope i'm not too late to the party. Thanks for all your effort in resolving this. However, i noticed that admins and coaches were not able to login if LOCKDOWN is also activated
screenshot at 2016-09-28 14-33-34

I created a PR to fix this - #5297. Now it works perfectly when lockdown is also activated.
Thanks again!

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming Sep 28, 2016

Member

This has already been fixed.. on which version did you encounter the issue?

I've been running with LOCKDOWN locally for a while, it was working also with admin/coach logins.

Member

benjaoming commented Sep 28, 2016

This has already been fixed.. on which version did you encounter the issue?

I've been running with LOCKDOWN locally for a while, it was working also with admin/coach logins.

@Aypak

This comment has been minimized.

Show comment
Hide comment
@Aypak

Aypak Sep 29, 2016

Contributor

I encountered this issue in the latest release. It only happened when both lockdown and simplified login were both activated. Thanks for reviewing the PR

Contributor

Aypak commented Sep 29, 2016

I encountered this issue in the latest release. It only happened when both lockdown and simplified login were both activated. Thanks for reviewing the PR

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming Oct 2, 2016

Member

@Aypak 's fix is implemented for the 0.17 release (current develop). I'm guessing because the fix was so simple and has already been confirmed as working, that we can skip any further confirmation and just close this issue :)

Member

benjaoming commented Oct 2, 2016

@Aypak 's fix is implemented for the 0.17 release (current develop). I'm guessing because the fix was so simple and has already been confirmed as working, that we can skip any further confirmation and just close this issue :)

@benjaoming benjaoming closed this Oct 2, 2016

@benjaoming benjaoming removed the has PR label Oct 2, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment