New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Not seeing Pictures display in 0.17.0 (multiple browsers) similar to: picture not displaying #5140 #5430

Closed
case485 opened this Issue Apr 4, 2017 · 8 comments

Comments

Projects
None yet
2 participants
@case485

case485 commented Apr 4, 2017

KaLite version 0.17.0
Host Raspberry Pi Jessie 4.4
Multiple browsers from windows client not displaying pictures of course content not displaying. Similar to #5140

I tried in both content packs i have loaded (french and English) and with 3 different browsers on my windows 10 client (Mozilla, IE and Chrome)

pic1
pic1_ie
pic2_chrome

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming Apr 5, 2017

Member

Hi @case485

This is not a browser issue, but the media from your Content Pack that's not showing up.

It would be nice if you could use the original issue template and answer questions like how you installed KA Lite - was it with the debian installer, and wsa it the ka-lite-raspberry-pi installer?

Try running:

kalite manage collectstatic
Member

benjaoming commented Apr 5, 2017

Hi @case485

This is not a browser issue, but the media from your Content Pack that's not showing up.

It would be nice if you could use the original issue template and answer questions like how you installed KA Lite - was it with the debian installer, and wsa it the ka-lite-raspberry-pi installer?

Try running:

kalite manage collectstatic
@case485

This comment has been minimized.

Show comment
Hide comment
@case485

case485 Apr 14, 2017

Here is how i installed the distribution :
apt-get -y install software-properties-common python-software-properties
echo "deb http://ppa.launchpad.net/learningequality/ka-lite/ubuntu xenial main" > /etc/apt/sources.list.d/ka-lite.list
apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 74F88ADB3194DD81
apt-get -y update
apt-get install -y ka-lite-raspberry-pi

case485 commented Apr 14, 2017

Here is how i installed the distribution :
apt-get -y install software-properties-common python-software-properties
echo "deb http://ppa.launchpad.net/learningequality/ka-lite/ubuntu xenial main" > /etc/apt/sources.list.d/ka-lite.list
apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 74F88ADB3194DD81
apt-get -y update
apt-get install -y ka-lite-raspberry-pi

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming Apr 14, 2017

Member

Thanks for getting back, I can confirm this now!

Member

benjaoming commented Apr 14, 2017

Thanks for getting back, I can confirm this now!

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming Apr 14, 2017

Member

I can also confirm that I've found the fix.

Member

benjaoming commented Apr 14, 2017

I can also confirm that I've found the fix.

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming Apr 14, 2017

Member

The following lines are in your /etc/nginx/sites-available/kalite.conf by mistake and should be deleted:

    location /content/assessment/khan {
        alias   /usr/share/kalite/assessment/khan/;
    }

After removing them, run sudo service nginx reload

I'm creating an update now. In case you delete the lines manually, just beware that when you upgrade the ka-lite-raspberry-pi package, you will probably get a warning where you should accept the "package maintainers version".

Within a few hours, a fix will be out (takes a while to build and upload)...

Member

benjaoming commented Apr 14, 2017

The following lines are in your /etc/nginx/sites-available/kalite.conf by mistake and should be deleted:

    location /content/assessment/khan {
        alias   /usr/share/kalite/assessment/khan/;
    }

After removing them, run sudo service nginx reload

I'm creating an update now. In case you delete the lines manually, just beware that when you upgrade the ka-lite-raspberry-pi package, you will probably get a warning where you should accept the "package maintainers version".

Within a few hours, a fix will be out (takes a while to build and upload)...

@case485

This comment has been minimized.

Show comment
Hide comment
@case485

case485 Apr 14, 2017

Amazing - thanks for all the hard work.

case485 commented Apr 14, 2017

Amazing - thanks for all the hard work.

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming Apr 14, 2017

Member

The fix is now in the stable ka-lite repo and the learningequality.org server is also serving an updated ka-lite-raspberry-pi_0.17.0-0ubuntu3_all.deb.

http://pantry.learningequality.org/downloads/ka-lite/0.17/installers/debian/ka-lite-raspberry-pi_0.17.0-0ubuntu3_all.deb

Thanks for finding this @case485 and sorry about the delayed investigation from my side.

Member

benjaoming commented Apr 14, 2017

The fix is now in the stable ka-lite repo and the learningequality.org server is also serving an updated ka-lite-raspberry-pi_0.17.0-0ubuntu3_all.deb.

http://pantry.learningequality.org/downloads/ka-lite/0.17/installers/debian/ka-lite-raspberry-pi_0.17.0-0ubuntu3_all.deb

Thanks for finding this @case485 and sorry about the delayed investigation from my side.

@benjaoming benjaoming closed this Apr 14, 2017

benjaoming added a commit that referenced this issue Apr 14, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment