New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Resource titles displaying in English instead of the chosen locale in the Teach tab #5494

Closed
radinamatic opened this Issue Jul 29, 2017 · 10 comments

Comments

Projects
None yet
4 participants
@radinamatic
Contributor

radinamatic commented Jul 29, 2017

Summary

If Spanish is selected by default, the resource titles are still displaying in English instead of Spanish inside the search dropdown and tabular report in the Teach tab.

This does not seem to be a contentpack issue as those items are present and localized in the Spanish topic tree, they are just not displaying here in the appropriate language, whether Spanish or French.

System information

  • Operating system: Ubuntu 17.04
  • Version: 0.17.2rc2-2
  • Browser: FF & Chrome

How to reproduce

  1. Log-in as one or more users, view some videos, or do some exercises
  2. Login as Admin or Coach
  3. Change the locale.
  4. Go to Teach tab and observe the tabular report at the bottom.

Screenshots

Spanish

virtualbox_ubuntu17 04_28_07_2017_19_06_18-titles

French

virtualbox_ubuntu17 04_29_07_2017_04_03_35

Real-life consequences

Coaches cannot interpret the results - let's fix it with the rest of the content in Spanish that we already managed to correct!

@mrpau-eugene

This comment has been minimized.

Show comment
Hide comment
@mrpau-eugene

mrpau-eugene Jul 31, 2017

Member

Btw, this issue is also existing in the demo server.

I tried adding _ in some variables in the tabular-view.handlebars but it still doesn't seem to get translated.

Correct me if I'm wrong, but I think the behavior on how we fetch the data is that it fetches the contents from the english database and not from spanish, french, etc.

@benjaoming do you have any other ideas why this happens?

Member

mrpau-eugene commented Jul 31, 2017

Btw, this issue is also existing in the demo server.

I tried adding _ in some variables in the tabular-view.handlebars but it still doesn't seem to get translated.

Correct me if I'm wrong, but I think the behavior on how we fetch the data is that it fetches the contents from the english database and not from spanish, french, etc.

@benjaoming do you have any other ideas why this happens?

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming Jul 31, 2017

Member

Btw, this issue is also existing in the demo server.

The demo server is running 0.16.9 which probably have similar issues.

I tried adding _ in some variables in the tabular-view.handlebars but it still doesn't seem to get translated.

These titles are from the content database, so isn't the problem that it uses the English contents regardless of the active user language?

Member

benjaoming commented Jul 31, 2017

Btw, this issue is also existing in the demo server.

The demo server is running 0.16.9 which probably have similar issues.

I tried adding _ in some variables in the tabular-view.handlebars but it still doesn't seem to get translated.

These titles are from the content database, so isn't the problem that it uses the English contents regardless of the active user language?

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming Jul 31, 2017

Member

Also, @mrpau-eugene - some of the missing msgids are added in #5496

Member

benjaoming commented Jul 31, 2017

Also, @mrpau-eugene - some of the missing msgids are added in #5496

@mrpau-eugene

This comment has been minimized.

Show comment
Hide comment
@mrpau-eugene

mrpau-eugene Aug 1, 2017

Member

These titles are from the content database, so isn't the problem that it uses the English contents regardless of the active user language?

Yes, that's most likely it.

Also, @mrpau-eugene - some of the missing msgids are added in #5496

Great! Will see if I can also find some missing msgids :)

Member

mrpau-eugene commented Aug 1, 2017

These titles are from the content database, so isn't the problem that it uses the English contents regardless of the active user language?

Yes, that's most likely it.

Also, @mrpau-eugene - some of the missing msgids are added in #5496

Great! Will see if I can also find some missing msgids :)

@radinamatic

This comment has been minimized.

Show comment
Hide comment
@radinamatic

radinamatic Aug 1, 2017

Contributor

@mrpau-eugene

so isn't the problem that it uses the English contents regardless of the active user language?

Yes, that's most likely it.

I hope I'm understanding correctly: what you want to say is that it isn't going to be a (big) problem to fix, right?

Because it is definitely a problem for the users to have them in English instead of the active user language... 😛

Contributor

radinamatic commented Aug 1, 2017

@mrpau-eugene

so isn't the problem that it uses the English contents regardless of the active user language?

Yes, that's most likely it.

I hope I'm understanding correctly: what you want to say is that it isn't going to be a (big) problem to fix, right?

Because it is definitely a problem for the users to have them in English instead of the active user language... 😛

@mrpau-eugene

This comment has been minimized.

Show comment
Hide comment
@mrpau-eugene

mrpau-eugene Aug 1, 2017

Member

@radinamatic Yeah. Seems like it won't take too long. I'll fix this as soon as possible.

Member

mrpau-eugene commented Aug 1, 2017

@radinamatic Yeah. Seems like it won't take too long. I'll fix this as soon as possible.

@mrpau-eugene

This comment has been minimized.

Show comment
Hide comment
@mrpau-eugene

mrpau-eugene Aug 4, 2017

Member

@radinamatic @benjaoming where should we target a PR for this? Should it be in the 0.17.3?

Member

mrpau-eugene commented Aug 4, 2017

@radinamatic @benjaoming where should we target a PR for this? Should it be in the 0.17.3?

@radinamatic

This comment has been minimized.

Show comment
Hide comment
@radinamatic

radinamatic Aug 4, 2017

Contributor

Is there a reason why it should not be included into the 0.17.2?
Partners in LatAm are expecting it... 😕

Contributor

radinamatic commented Aug 4, 2017

Is there a reason why it should not be included into the 0.17.2?
Partners in LatAm are expecting it... 😕

@mrpau-eugene

This comment has been minimized.

Show comment
Hide comment
@mrpau-eugene

mrpau-eugene Aug 4, 2017

Member

@radinamatic no reason in particular.. I'm just making sure 😄

Member

mrpau-eugene commented Aug 4, 2017

@radinamatic no reason in particular.. I'm just making sure 😄

@mrpau-eugene mrpau-eugene added this to the 0.17.2 milestone Aug 4, 2017

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming Aug 18, 2017

Member

I'm happy to add this in 0.17.2 since the fix is very clean. Will verify the CI build and merge soon.

Member

benjaoming commented Aug 18, 2017

I'm happy to add this in 0.17.2 since the fix is very clean. Will verify the CI build and merge soon.

benjaoming added a commit that referenced this issue Aug 18, 2017

@benjaoming benjaoming closed this Aug 18, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment