Skip to content
Permalink
Browse files

Remove reference to lisp from default.nix

There is no longer a submodule which provides elisp, so the `cp` portion of this expression fails.

Also remove obsolete comment about presence of gitmodules.
  • Loading branch information
purcell authored and tbm committed Dec 26, 2019
1 parent 8702c10 commit 98cb8b1dc7a0d6ea4964e971dbcaa9ea669dc1f9
Showing with 0 additions and 9 deletions.
  1. +0 −9 default.nix
@@ -9,21 +9,12 @@ in
stdenv.mkDerivation {
name = "ledger-${version}-${rev}";

# NOTE: fetchgit because ledger has submodules not included in the
# default github tarball.
src = ./.;

buildInputs = [ cmake boost gmp mpfr libedit python texinfo gnused ];

enableParallelBuilding = true;

# Skip byte-compiling of emacs-lisp files because this is currently
# broken in ledger...
postInstall = ''
mkdir -p $out/share/emacs/site-lisp/
cp -v "$src/lisp/"*.el $out/share/emacs/site-lisp/
'';

cmakeFlags = [ "-DCMAKE_INSTALL_LIBDIR=lib" ];

buildPhase = "make -j$NIX_BUILD_CORES";

0 comments on commit 98cb8b1

Please sign in to comment.
You can’t perform that action at this time.