Permalink
Browse files

Lock to Rake 0.9.2, rather than 0.9.2.2

We had originally allowed the use of 0.9.2.2 so that we could use Ruby
1.9.3 to develop against, but a change in rummager
(alphagov/rummager@c7171b0) locking
it to 0.9.2 explicitly, in combination with the fact that both apps
are deployed on the same machine, means that we have to revert this to
avoid Passenger freaking out.

Rake 0.9.2 is the version which puppet ensures, and so rather than try to retain this flexibility, it is easier to move Whitehall into line with the strict constraint.

Note that this means we can no longer develop using Ruby 1.9.3 locally.
  • Loading branch information...
1 parent e0ac71e commit 4f38dde1b6eb0900feebe29fbd840a897f01b71d @lazyatom-and-floehopper lazyatom-and-floehopper committed Feb 3, 2012
Showing with 3 additions and 3 deletions.
  1. +1 −1 Gemfile
  2. +2 −2 Gemfile.lock
View
@@ -11,7 +11,7 @@ gem 'govspeak', :git => 'git://github.com/alphagov/govspeak.git'
gem 'validates_email_format_of'
gem 'friendly_id', '4.0.0.beta14'
gem 'nokogiri'
-gem 'rake', '0.9.2.2'
+gem 'rake', '0.9.2'
gem 'boomerang-rails'
gem 'slimmer', '1.1.19'
gem 'plek'
View
@@ -213,7 +213,7 @@ GEM
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (~> 0.14.6)
- rake (0.9.2.2)
+ rake (0.9.2)
rdoc (3.12)
json (~> 1.4)
rest-client (1.6.7)
@@ -296,7 +296,7 @@ DEPENDENCIES
rack (= 1.3.5)
rails (= 3.1.3)
rails-dev-boost!
- rake (= 0.9.2.2)
+ rake (= 0.9.2)
router-client!
rummageable!
sass-rails (~> 3.1.0)

0 comments on commit 4f38dde

Please sign in to comment.