Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
A ZF2 module that implements DoctrineExtensions with SpiffyDoctrine.
PHP
Branch: master

change di usage to new path to make extensions working

doctrine_evm -> parameters -> opts -> subscribers
latest commit e5daddaae4
@Mischosch Mischosch authored

README.md

SpiffyDoctrineExtensions Module for Zend Framework 2

The SpiffyDoctrineExtensions module sets up DoctrineExtensions to work with SpiffyDoctrine.

Requirements

  • Zend Framework 2
  • SpiffyDoctrine

Installation

The simplest way to install is to clone the repository into your /modules directory add the SpiffyDoctrineExtensions key to your modules array before your Application module key and after SpiffyDoctrine.

  1. cd my/project/folder
  2. git clone https://SpiffyJr@github.com/SpiffyJr/SpiffyDoctrine.git modules/SpiffyDoctrine --recursive
  3. open my/project/folder/configs/application.config.php and add 'SpiffyDoctrineExtensions' to your 'modules' parameter after 'SpiffyDoctrine'.
  4. Add any DoctrineExtensions you want to use following the configuration below to your Application module config.

Example standard configuration

<?php
return array(
    'di' => array(
        'instance' => array(
            'doctrine-eventmanager' => array(
                'injections' => array(
                    'Gedmo\Sluggable\SluggableListener'
                ),
            )
        )
    )
);
Something went wrong with that request. Please try again.