Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support for lower version of flask #37

Closed
davislx opened this issue Aug 16, 2013 · 7 comments

Comments

@davislx
Copy link
Contributor

commented Aug 16, 2013

We are running flask version 0.8. I took a brief look at the code, I believe the dependency flask_oauthlib has on flask should already be there in version 0.8. Instead of downloading the source code and modifying the dependency in setup.py, is there a plan for backward compatibility support?

@lepture

This comment has been minimized.

Copy link
Owner

commented Aug 17, 2013

@davislx I've tested it on Flask 0.8.0, it works.

@davislx

This comment has been minimized.

Copy link
Contributor Author

commented Aug 17, 2013

@lepture Thank you for your quick response. This confirms my prior intuition. I've seen the change in setup.py, now I just need to wait for the next release.

@davislx

This comment has been minimized.

Copy link
Contributor Author

commented Aug 17, 2013

Ohh, I believe oauthlib 0.5 is necessary. Tested against 0.4.1, got an error of cannot import RequestValidator. I believe it was added afterwards.

@lepture

This comment has been minimized.

Copy link
Owner

commented Aug 17, 2013

@davislx Yes, oauthlib 0.5 is required for OAuth1 provider.

Are you using the client part of this module? Or the provider part?

@davislx

This comment has been minimized.

Copy link
Contributor Author

commented Aug 17, 2013

@lepture I am using the oauth2 provider part.

@lepture

This comment has been minimized.

Copy link
Owner

commented Aug 17, 2013

@davislx Star and watch this repo for latest updates.

You can install the source code for development:

$ pip install -e git+https://github.com/lepture/flask-oauthlib.git#egg=Flask-OAuthlib

If you watched this repo, you will get notified when Flask-OAuthlib is released.

mvexel added a commit to mvexel/flask-oauthlib that referenced this issue Aug 19, 2013

Merge remote-tracking branch 'upstream/master'
* upstream/master:
  Changelog for 0.3.0-dev
  Backward compatible for lower version of Flask. lepture#37
  Add badge of pypi version. Fix typo on OAuth1 server.
  linkedin works. another non-standard oauth2 service.
  works with new proposal of oauthlib/oauthlib#201 now
  add example for linkedin
  fix for lint
  use create_response method
  my mistake for get property
  pre configuration for lepture#34
  bugfix get property for client
  change twitter to 1.1
  make utils public
  improve doc strings of the module
  Wrapped rv.data with to_unicode
  Created test for bad user credentials. Also updated usergetter to query the database for the given username instead of just returning the first record.
  Now checks to make sure user isn\'t None
@lepture

This comment has been minimized.

Copy link
Owner

commented Aug 23, 2013

@davislx 0.3.1 is released.

@lepture lepture closed this Aug 23, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.