Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unknown option `atomic' #2400

Closed
wickedest opened this issue Jan 2, 2020 · 5 comments
Closed

Unknown option `atomic' #2400

wickedest opened this issue Jan 2, 2020 · 5 comments
Labels
bug

Comments

@wickedest
Copy link

@wickedest wickedest commented Jan 2, 2020

Expected Behavior

Braking change. Expect that lerna publish to work as before.

Current Behavior

lerna publish fails with:

lerna notice cli v3.20.1
lerna info versioning independent
lerna info ci enabled
lerna info require-scripts enabled
...
lerna info execute Skipping releases
lerna info git Pushing tags...
lerna ERR! Error: Command failed: git push --follow-tags --no-verify --atomic origin master
lerna ERR! error: unknown option `atomic'

Possible Solution

Related to #2393

Context

This breaks our CI. We are blocked and cannot publish our modules.

Your Environment

Executable Version
lerna --version 3.20.1
npm --version 6.1.0
node --version 8.11.3
@evocateur evocateur added the bug label Jan 2, 2020
@evocateur
Copy link
Member

@evocateur evocateur commented Jan 2, 2020

I guess 2b9b210 wasn't sufficient. What version of git are you using?

@wickedest
Copy link
Author

@wickedest wickedest commented Jan 2, 2020

git version 2.1.4

@wickedest
Copy link
Author

@wickedest wickedest commented Jan 2, 2020

While 2.1.4 is laughably old (Dec 17 2014), it is part of a cypress docker base image that uses node:8.12. I had a bit of a dig through the lerna documentation, and I couldn't see anything about a minimum version of git. It might be good to publish that.

@evocateur evocateur closed this in 6f0e2bb Jan 2, 2020
@evocateur
Copy link
Member

@evocateur evocateur commented Jan 2, 2020

Yeah, I spent the last 20 minutes or so cursing google's inability to find what version of git is supported by various CI providers. I think 2.1.4 is the latest provided by debian 8 (jessie)'s core packages.

In any event, my fallback was too strict, I'll be releasing a patch once CI passes

@evocateur
Copy link
Member

@evocateur evocateur commented Jan 2, 2020

Published in v3.20.2

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.