Permalink
Browse files

Remove jeweler

  • Loading branch information...
1 parent 628980f commit 8a7e4811ecbd601fa0995b381e08ab6874e789a2 @leshill committed Nov 29, 2010
Showing with 25 additions and 95 deletions.
  1. +1 −1 .gitignore
  2. +0 −10 Gemfile.lock
  3. +3 −16 Rakefile
  4. +0 −1 VERSION
  5. +3 −0 lib/resque_spec/version.rb
  6. +18 −67 resque_spec.gemspec
View
@@ -16,7 +16,7 @@ tmtags
## PROJECT::GENERAL
coverage
rdoc
-pkg
.bundle
+*.gem
## PROJECT::SPECIFIC
View
@@ -9,14 +9,7 @@ GEM
remote: http://rubygems.org/
specs:
diff-lcs (1.1.2)
- gemcutter (0.6.1)
- git (1.2.5)
- jeweler (1.4.0)
- gemcutter (>= 0.1.0)
- git (>= 1.2.5)
- rubyforge (>= 2.0.0)
json (1.4.6)
- json_pure (1.4.6)
rack (1.2.1)
redis (2.0.8)
redis-namespace (0.8.0)
@@ -36,8 +29,6 @@ GEM
rspec-mocks (2.0.0.beta.22)
rspec-core (= 2.0.0.beta.22)
rspec-expectations (= 2.0.0.beta.22)
- rubyforge (2.0.4)
- json_pure (>= 1.1.7)
sinatra (1.0)
rack (>= 1.0)
vegas (0.1.7)
@@ -47,7 +38,6 @@ PLATFORMS
ruby
DEPENDENCIES
- jeweler (>= 1.4.0)
resque (>= 1.6.0)
resque_spec!
rspec (>= 2.0.0.beta.12)
View
@@ -1,19 +1,6 @@
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = "resque_spec"
- gem.summary = %{RSpec matchers for Resque}
- gem.description = %{RSpec matchers for Resque}
- gem.email = "leshill@gmail.com"
- gem.homepage = "http://github.com/leshill/resque_spec"
- gem.authors = ["Les Hill"]
- gem.add_dependency "resque", ">= 1.6.0"
- gem.add_dependency "rspec", ">= 2.0.0.beta.12"
- gem.add_development_dependency "jeweler", ">= 1.4.0"
- end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
+task :gem => :build
+task :build do
+ system "gem build resque_spec.gemspec"
end
require 'rspec/core/rake_task'
View
@@ -1 +0,0 @@
-0.4.0
@@ -0,0 +1,3 @@
+module ResqueSpec
+ VERSION = "0.4.0"
+end
View
@@ -1,74 +1,25 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
-# -*- encoding: utf-8 -*-
+lib = File.expand_path('../lib/', __FILE__)
+$:.unshift lib unless $:.include?(lib)
+
+require "resque_spec/version"
Gem::Specification.new do |s|
- s.name = %q{resque_spec}
- s.version = "0.4.0"
+ s.required_rubygems_version = '>= 1.3.6'
+
+ s.name = 'resque_spec'
+ s.version = ResqueSpec::VERSION
+ s.authors = ['Les Hill']
+ s.date = '2010-11-28'
+ s.description = 'RSpec matchers for Resque'
+ s.summary = 'RSpec matchers for Resque'
+ s.homepage = 'http://github.com/leshill/resque_spec'
+ s.email = 'leshill@gmail.com'
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Les Hill"]
- s.date = %q{2010-09-16}
- s.description = %q{RSpec matchers for Resque}
- s.email = %q{leshill@gmail.com}
- s.extra_rdoc_files = [
- "LICENSE",
- "README.md"
- ]
- s.files = [
- ".document",
- ".gitignore",
- ".rspec",
- ".rvmrc",
- "Gemfile",
- "Gemfile.lock",
- "LICENSE",
- "README.md",
- "Rakefile",
- "VERSION",
- "lib/resque_spec.rb",
- "lib/resque_spec/resque_scheduler_spec.rb",
- "lib/resque_spec/resque_spec.rb",
- "resque_spec.gemspec",
- "spec/resque_scheduler_spec_spec.rb",
- "spec/resque_spec_spec.rb",
- "spec/spec_helper.rb",
- "spec/support/account.rb",
- "spec/support/address.rb",
- "spec/support/person.rb"
- ]
- s.homepage = %q{http://github.com/leshill/resque_spec}
- s.rdoc_options = ["--charset=UTF-8"]
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{RSpec matchers for Resque}
- s.test_files = [
- "spec/resque_scheduler_spec_spec.rb",
- "spec/resque_spec_spec.rb",
- "spec/spec_helper.rb",
- "spec/support/account.rb",
- "spec/support/address.rb",
- "spec/support/person.rb"
- ]
+ s.require_path = "lib"
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
+ s.files = Dir.glob("lib/**/*") + %w(LICENSE README.md Rakefile)
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<resque>, [">= 1.6.0"])
- s.add_runtime_dependency(%q<rspec>, [">= 2.0.0.beta.12"])
- s.add_development_dependency(%q<jeweler>, [">= 1.4.0"])
- else
- s.add_dependency(%q<resque>, [">= 1.6.0"])
- s.add_dependency(%q<rspec>, [">= 2.0.0.beta.12"])
- s.add_dependency(%q<jeweler>, [">= 1.4.0"])
- end
- else
- s.add_dependency(%q<resque>, [">= 1.6.0"])
- s.add_dependency(%q<rspec>, [">= 2.0.0.beta.12"])
- s.add_dependency(%q<jeweler>, [">= 1.4.0"])
- end
+ s.add_runtime_dependency('resque', ['>= 1.6.0'])
+ s.add_runtime_dependency('rspec', ['>= 2.0.0.beta.12'])
end

0 comments on commit 8a7e481

Please sign in to comment.