New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

npm install errors with ENOENT 34 #6

Closed
tamer-hassan opened this Issue Oct 22, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@tamer-hassan
Copy link
Contributor

tamer-hassan commented Oct 22, 2015

I ran into this issue twice
first time I thought I solved it with:
touch .npmignore in the project root then rerunning npm install
per the solution here: http://stackoverflow.com/questions/17990647/npm-install-errors-with-error-enoent-chmod
then I encountered another error (both on Ubuntu Server 14.04 and Linux Mint 17.1 Desktop) where it was looking for a "node" binary instead of a "nodejs" binary.
For that I had to:
sudo ln -s /usr/bin/nodejs /usr/bin/node

Perhaps these two steps should be noted in the documentation, to save others the time and research effort in solving this.

@sroutier

This comment has been minimized.

Copy link
Collaborator

sroutier commented Oct 23, 2015

Thanks for the tips, I noted both in the README.
/s

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment