Fixes to Rails 3 deprecation warnings #31

Open
wants to merge 3 commits into
from

Conversation

Projects
None yet
1 participant

craic commented Oct 27, 2010

Hi
I've fixed a couple of Deprecation warnings in Rails 3.0.1/Ruby 1.9.2 by moving the require on the controller_extension into the top-level init.rb and using Rails.env instead of RAILS_ENV.

I had to change the test_helper to fake a Rails.env method. It passes tests in Ruby 1.8.7/Rails 2.3.8 and Ruby 1.9.2/Rails 3.0.1

Hope you can merge them into the plugin

--Rob Jones

craic commented Oct 27, 2010

I spoke too soon - the plugin works in both Ruby 1.8.7 / Rails 2.3.8 and Ruby 1.9.2 / Rails 3.0.1 and the tests pass in Ruby 1.8.7 but they crash in Ruby 1.9.2 - the issue is a Gem::LoadError

/Users/jones/.rvm/rubies/ruby-1.9.2-p0/lib/ruby/1.9.1/rubygems.rb:238:in `activate': can't activate actionpack (= 2.3.8, runtime) for [], already activated actionpack-3.0.1 for

Not sure what the issue is. I am running ruby 1.9.2 under rvm.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment