Skip to content

Math::GSL tests uses installed version instead of in-repo version #27

Closed
leto opened this Issue Aug 30, 2011 · 0 comments

1 participant

@leto
Owner
leto commented Aug 30, 2011

``` prove -lrv t/Vector.t
Can't load '/media/ssd/git/math--gsl/blib/arch/auto/Math/GSL/Vector/Vector.so' for module Math::GSL::Vector: /media/ssd/git/math--gsl/blib/arch/auto/Math/GSL/Vector/Vector.so: undefined symbol: gsl_vector_int_equal at /usr/lib/perl/5.10/DynaLoader.pm line 192.
at /media/ssd/git/math--gsl/blib/lib/Math/GSL/Vector.pm line 11
Compilation failed in require at /media/ssd/git/math--gsl/blib/lib/Math/GSL.pm line 11.
BEGIN failed--compilation aborted at /media/ssd/git/math--gsl/blib/lib/Math/GSL.pm line 11.
Compilation failed in require at t/Vector.t line 4.
BEGIN failed--compilation aborted at t/Vector.t line 4.

Looks like your test exited with 2 before it could output anything.

This error went away when I installed Math::GSL, then ran the tests again.

The test suite should not finding an installed Math::GSL before the in-repo version.

@leto leto closed this in 262b0e2 Sep 17, 2011
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.