Skip to content
Browse files

[travis] Declare which versions of perl to test under

  • Loading branch information...
1 parent 0bce82e commit 948379671313817c56a3337ec4e6bdcc80dc89ea @leto committed Jul 12, 2012
Showing with 5 additions and 6 deletions.
  1. +5 −6 .travis.yml
View
11 .travis.yml
@@ -1,12 +1,11 @@
language: "perl"
+perl:
+ - "5.14"
+ - "5.12"
+ - "5.10"
before_script:
-# - sudo apt-get install liblocal-lib-perl libgmp3-dev
- sudo apt-get install libgmp3-dev
-# - curl -L http://cpanmin.us | sudo perl - --self-upgrade
-# - perl -Mlocal::lib >> /tmp/local_lib_junk.sh && source /tmp/local_lib_junk.sh
-# - export CI_USER=$USER
-# - sudo chown -R $CI_USER ~/.cpanm ~/perl5
- - cpanm Test::Pod
+ - cpanm Test::Pod # optional dependency
script: "perl Build.PL; ./Build test"
# branches:
# only:

0 comments on commit 9483796

Please sign in to comment.
Something went wrong with that request. Please try again.