PL/Parrot doesn't compile on Parrot 3.5.0 and Postgres 8.4.8 #35

Closed
leto opened this Issue Jul 12, 2011 · 1 comment

Comments

Projects
None yet
1 participant
Owner

leto commented Jul 12, 2011

Found Parrot Virtual Machine 3.5.0 5718bb97e10b7d4c43ee0189d925eba33548bbb2

./bin/text2macro.pl plparrot_secure.pir > plparrot.h
./bin/text2macro.pl plperl6.pir > plperl6.h
gcc  -fstack-protector -L/usr/local/lib -L/home/leto/git/parrot/installed_parrot/lib -lparrot /home/leto/git/parrot/installed_parrot/lib//3.5.0-devel/parrot_config.o -g -O2 -g -Wall -O2 -fPIC -Wall -Wmissing-prototypes -Wpointer-arith -Wdeclaration-after-statement -Wendif-labels -fno-strict-aliasing -fwrapv -g -fpic -DHAS_PERL6 -D'PERL6PBC="/home/leto/git/parrot/installed_parrot/lib/3.5.0-devel/languages/perl6/perl6.pbc"' -I/home/leto/git/parrot/installed_parrot/include/3.5.0-devel -I. -I. -I/usr/include/postgresql/8.4/server -I/usr/include/postgresql/internal -D_GNU_SOURCE -I/usr/include/libxml2  -I/usr/include/tcl8.5  -c -o plparrot.o plparrot.c
In file included from /usr/include/postgresql/8.4/server/postgres.h:47,
                 from plparrot.c:14:
/usr/include/postgresql/8.4/server/c.h:93:1: warning: "_" redefined
In file included from /home/leto/git/parrot/installed_parrot/include/3.5.0-devel/parrot/embed.h:13,
                 from plparrot.c:8:
/home/leto/git/parrot/installed_parrot/include/3.5.0-devel/parrot/parrot.h:214:1: warning: this is the location of the previous definition
In file included from /usr/include/postgresql/8.4/server/postgres.h:47,
                 from plparrot.c:14:
/usr/include/postgresql/8.4/server/c.h:112:1: warning: "gettext_noop" redefined
In file included from /home/leto/git/parrot/installed_parrot/include/3.5.0-devel/parrot/embed.h:13,
                 from plparrot.c:8:
/home/leto/git/parrot/installed_parrot/include/3.5.0-devel/parrot/parrot.h:215:1: warning: this is the location of the previous definition
In file included from /usr/include/postgresql/8.4/server/postgres.h:48,
                 from plparrot.c:14:
/usr/include/postgresql/8.4/server/utils/elog.h:51:1: warning: "PANIC" redefined
In file included from /home/leto/git/parrot/installed_parrot/include/3.5.0-devel/parrot/parrot.h:245,
                 from /home/leto/git/parrot/installed_parrot/include/3.5.0-devel/parrot/embed.h:13,
                 from plparrot.c:8:
/home/leto/git/parrot/installed_parrot/include/3.5.0-devel/parrot/exceptions.h:279:1: warning: this is the location of the previous definition
In file included from /usr/include/postgresql/8.4/server/access/xlog.h:17,
                 from /usr/include/postgresql/8.4/server/access/heapam.h:20,
                 from plparrot.c:15:
/usr/include/postgresql/8.4/server/storage/buf.h:23: error: conflicting types for ‘Buffer’
/home/leto/git/parrot/installed_parrot/include/3.5.0-devel/parrot/pobj.h:30: note: previous declaration of ‘Buffer’ was here
In file included from /usr/include/postgresql/8.4/server/nodes/execnodes.h:21,
                 from /usr/include/postgresql/8.4/server/executor/execdesc.h:18,
                 from /usr/include/postgresql/8.4/server/utils/portal.h:49,
                 from /usr/include/postgresql/8.4/server/executor/spi.h:17,
                 from plparrot.c:18:
/usr/include/postgresql/8.4/server/nodes/plannodes.h:585: error: conflicting types for ‘Hash’
/home/leto/git/parrot/installed_parrot/include/3.5.0-devel/parrot/parrot.h:229: note: previous declaration of ‘Hash’ was here
plparrot.c: In function ‘_PG_init’:
plparrot.c:120: warning: implicit declaration of function ‘Parrot_set_config_hash’
plparrot.c: In function ‘debug’:
plparrot.c:597: warning: format not a string literal and no format arguments
make: *** [plparrot.o] Error 1
Owner

leto commented Nov 16, 2011

I think this was fixed. If not, a new issue on a recent Parrot will be created.

leto closed this Nov 16, 2011

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment