Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Release a version compatible with template-haskell-2.15 #29

Closed
DanBurton opened this issue Sep 29, 2019 · 1 comment
Closed

Release a version compatible with template-haskell-2.15 #29

DanBurton opened this issue Sep 29, 2019 · 1 comment

Comments

@DanBurton
Copy link

@DanBurton DanBurton commented Sep 29, 2019

Kindly do a hackage revision, or release a new version that allows for template-haskell-2.15.

It is currently constrained to template-haskell < 2.15, but it seems to work fine.

I was able to reproduce a successful build & test locally like so:

stack unpack freer-simple-1.2.1.0 && cd freer-simple-1.2.1.0
edit stack.yaml # add the following stack.yaml
edit freer-simple.cabal  # relax the constraint on template-haskell
stack build --test --bench --no-run-benchmarks --fast
# stack.yaml
resolver: nightly-2019-09-29
extra-deps:
  - extensible-effects-5.0.0.1@sha256:2ed0bee04c8bf334358147da6d92ff31e9fbbefceb75ef3e408a0d858aec0cc6,9013
@lexi-lambda

This comment has been minimized.

Copy link
Owner

@lexi-lambda lexi-lambda commented Oct 5, 2019

Fixed in freer-simple-1.2.1.1.

@lexi-lambda lexi-lambda closed this Oct 5, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.