Swift Objective-C Ruby Other
Fetching latest commit…
Cannot retrieve the latest commit at this time.

README.md

IINA

IINA is the modern video player for macOS.

Website · Releases · Telegram Group


Features

  • Based on mpv, which provides the best decoding capacity on macOS
  • Designed for modern macOS (10.11+), aims to offer the best user experience
  • All the features you need for videos, audios, subtitles, playlist, chapters and so on
  • Force Touch, Picture-in-picture and (advanced) Touch Bar support
  • Customizable user interface including color schemes and on screen controller (OSC) layout
  • Standalone Music Mode designed for audio files
  • Thumbnail preview for the whole timeline like YouTube
  • Online subtitle searching and intelligent local subtitle matching
  • Unlimited playback history
  • Convenient and interactive settings for video/audio filters
  • Fully customizable keyboard, mouse and trackpad gesture control
  • MPV config files and script system are available for advanced users
  • Command Line Tool and browser extensions provided
  • Still in active development

Build

Use pre-compiled dylibs

  1. Please make sure CocoaPods is installed.

gem

sudo gem install cocoapods

homebrew

brew install cocoapods
  1. Run pod install in project root directory.
pod install
  1. Open .xcworkspace file using Xcode 10.

Due to a cocoapods bug, before cocoapods 1.6.0 is released, you need to do extra work to build IINA.

  • Find file iina/Pods/Target Support Files/Pods-iina/Pods-iina-frameworks.sh
  • Jump to line 104, change EXPANDED_CODE_SIGN_IDENTITY to EXPANDED_CODE_SIGN_IDENTITY:-

If you are unwilling to use the provided dylibs, follow the instructions below.

Build with the latest mpv

  • Install mpv

    brew install mpv --with-uchardet
    

    Feel free to include any other libraries if you like.

  • Copy latest header files into libmpv/include/mpv/

  • other/parse_doc.rb

    This script will fetch the latest mpv documentation and generate MPVOption.swift, MPVCommand.swift and MPVProperty.swift. This is only needed when updating libmpv. Note that if the API changes, the player source code may also need to be changed.

  • other/change_lib_dependencies.rb

    This script will deploy the depended libraries into libmpv/libs. Make sure you have a phase copying of all these dylibs in Xcode's build settings.

Contributing

Please read CONTRIBUTING.md before opening an issue or pull request.

Please ask for permission from the author before starting working on a pull request to make sure that there's not someone else working on the same feature.

Any feedback/contribution is appreciated!

Translation

Please check Translation Status first. If a language is labeled as "Need help", then please feel free to update the translation. If it doesn't contain your language, it will be awesome to submit a new translation. Please contact the author (@lhc70000) if you don't know how to submit translations using GitHub.