Skip to content
Permalink
Browse files

appcompat > androidx

new Android api version
new release
  • Loading branch information...
Brianvdb committed May 1, 2019
1 parent d4a9ea9 commit 0a83c096073fc77f368e67af742cf9086869d09d
@@ -10,7 +10,7 @@ ext {
siteUrl = 'https://github.com/bravobit/FFmpeg-Android'
gitUrl = 'https://github.com/bravobit/FFmpeg-Android.git'

libraryVersion = '1.1.5'
libraryVersion = '1.1.6'

developerId = 'Bravobit'
developerName = 'Bravobit'
@@ -22,13 +22,13 @@ ext {
}

android {
compileSdkVersion 27
compileSdkVersion 28

defaultConfig {
minSdkVersion 16
targetSdkVersion 27
versionCode 15
versionName "1.1.5"
targetSdkVersion 28
versionCode 16
versionName "1.1.6"
}

compileOptions {
@@ -48,7 +48,7 @@ android {
dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])

implementation 'com.android.support:appcompat-v7:27.1.1'
implementation 'androidx.appcompat:appcompat:1.0.2'
}

apply plugin: 'com.github.dcendents.android-maven'
@@ -98,7 +98,6 @@ version = libraryVersion

if (project.hasProperty("android")) { // Android libraries
task sourcesJar(type: Jar) {
classifier = 'sources'
from android.sourceSets.main.java.srcDirs
}

@@ -108,13 +107,11 @@ if (project.hasProperty("android")) { // Android libraries
}
} else { // Java libraries
task sourcesJar(type: Jar, dependsOn: classes) {
classifier = 'sources'
from sourceSets.main.allSource
}
}

task javadocJar(type: Jar, dependsOn: javadoc) {
classifier = 'javadoc'
from javadoc.destinationDir
}

@@ -6,7 +6,7 @@ buildscript {
jcenter()
}
dependencies {
classpath 'com.android.tools.build:gradle:3.1.2'
classpath 'com.android.tools.build:gradle:3.4.0'
classpath 'com.jfrog.bintray.gradle:gradle-bintray-plugin:1.7.3'
classpath 'com.github.dcendents:android-maven-gradle-plugin:1.5'
}
@@ -0,0 +1,2 @@
android.enableJetifier=true
android.useAndroidX=true
@@ -1,6 +1,6 @@
#Wed Mar 28 16:53:58 CEST 2018
#Wed May 01 16:38:52 CEST 2019
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.4-all.zip
distributionUrl=https\://services.gradle.org/distributions/gradle-5.1.1-all.zip
@@ -1,12 +1,12 @@
apply plugin: 'com.android.application'

android {
compileSdkVersion 27
compileSdkVersion 28

defaultConfig {
applicationId "nl.bravobit.ffmpeg.example"
minSdkVersion 16
targetSdkVersion 27
targetSdkVersion 28
versionCode 1
versionName "1.0.1"
}
@@ -28,10 +28,10 @@ dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])

// Android libraries
implementation 'com.android.support:appcompat-v7:27.1.1'
implementation 'androidx.appcompat:appcompat:1.0.2'

// Misc
implementation 'com.jakewharton.timber:timber:4.6.1'
implementation 'com.jakewharton.timber:timber:4.7.1'

// FFmpeg project
implementation project(':android-ffmpeg')
@@ -2,7 +2,7 @@

import android.os.Bundle;
import android.os.Handler;
import android.support.v7.app.AppCompatActivity;
import androidx.appcompat.app.AppCompatActivity;

import nl.bravobit.ffmpeg.ExecuteBinaryResponseHandler;
import nl.bravobit.ffmpeg.FFmpeg;

0 comments on commit 0a83c09

Please sign in to comment.
You can’t perform that action at this time.