Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
tool for creating supermin appliances (formerly called febootstrap). PLEASE DO NOT USE GITHUB FOR ISSUES OR PULL REQUESTS. See the website for how to file a bug or contact us. http://libguestfs.org
OCaml C Perl Shell CSS

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
debian
gnulib @ a88d256
helper
html
lib
m4
.depend
.gitignore
.gitmodules
COPYING
Makefile.am
README
autobuild.sh
autogen.sh
config.ml.in
configure.ac
febootstrap.ml
febootstrap.pod
febootstrap_cmdline.ml
febootstrap_cmdline.mli
febootstrap_debian.ml
febootstrap_package_handlers.ml
febootstrap_package_handlers.mli
febootstrap_pacman.ml
febootstrap_utils.ml
febootstrap_utils.mli
febootstrap_yum_rpm.ml

README

febootstrap - Bootstrapping tool for creating supermin appliances
by Richard W.M. Jones (rjones@redhat.com)
http://people.redhat.com/~rjones/febootstrap
----------------------------------------------------------------------

febootstrap is a tool for building supermin appliances.  These are
tiny appliances [similar to virtual machines], usually around 100KB in
size, which get fully instantiated on-the-fly in a fraction of a
second when you need to boot one of them.

A complete description is in the febootstrap(8) man page.

IMPORTANT NOTE FOR USERS OF FEBOOTSTRAP 2.x:
  febootstrap 3.x is a complete rewrite.  febootstrap 2.x could only
  build Fedora distributions.  This version can build many varieties
  of Linux distros.  3.x only builds supermin appliances, it does not
  build chroots.  3.x does not build cross-distro, cross-release or
  cross-architecture systems.  If you want febootstrap 2.x, please use
  the 'febootstrap-2.x' branch from the git repository.

Requirements
------------

  ocaml

  ocaml findlib ("ocamlfind" program)

  perldoc
    - This is just used to generate the manpage.

  bash

  gcc

  gawk

  libcom_err
  libext2fs
  /sbin/mke2fs
    - These are part of e2fsprogs.

For Fedora/RHEL:

  rpm
  yum
  yumdownloader

For Debian/Ubuntu:

  dpkg
  aptitude

Optional
--------

These are only needed if you plan to boot the supermin appliances you
are building:

  qemu >= 0.13
  kernel >= 2.6.36

Building and installing
-----------------------

  ./configure
  make
  sudo make install

Feedback and bugs
-----------------

Send feedback to libguestfs@redhat.com.  You can file bugs in
https://bugzilla.redhat.com/ (under "Fedora", "febootstrap")

Something went wrong with that request. Please try again.