IPMI password #4686

Closed
githubuserx opened this Issue Oct 1, 2016 · 0 comments

Projects

None yet

2 participants

@githubuserx
Contributor
githubuserx commented Oct 1, 2016 edited

DO NOT DELETE THIS INFORMATION.

Please read this information carefully.

  • Is your install up to date? Updating your install
    Please do not submit an issue if your install is not up to date within the last 24 hours or on a stable monthly release.
  • Please include all of the information between the ==================================== section of ./validate.php.
  • If you would like us to add a new device then please provide the information asked for here
  • Please provide as much detail as possible.

After installing ipmitool and setting the right protocol in the config, a connection could not be established and I got an error about wrong credentials.
Eventually I found out that a # character in my password was the culprit. It seems that it is not escaped in the generated ipmitool command and thus commenting out parts of the password.
I use a different password now as a workaround.

@laf laf added the Bug label Oct 1, 2016
@Zaxmy Zaxmy pushed a commit to Zaxmy/librenms that referenced this issue Oct 3, 2016
Johan issue #4686 make sure shell doesnt interpret part of the password to …
…ipmitool as shell escape sequences
d6b4a2b
@Zaxmy Zaxmy referenced this issue Oct 3, 2016
Merged

Issue 4686 #4703

2 of 2 tasks complete
@laf laf closed this Oct 3, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment