Riverbed in Librenms #5170

Closed
anden4380 opened this Issue Dec 14, 2016 · 40 comments

Projects

None yet

4 participants

@anden4380

Is it possible to get these graphs in Librenms?

image

I have all the XML files for Cacti maybe that can be used?

Riverbed-Graph.templates-09.02.2007.zip

@laf laf added the New-Device label Dec 14, 2016
@Rosiak Rosiak self-assigned this Dec 16, 2016
@laf
Member
laf commented Jan 9, 2017

Please provide the information asked for in point 3 when creating an issue.

@anden4380

Witch info?

@laf
Member
laf commented Jan 10, 2017

The info asked for when creating an issue, it says not to delete it but you've deleted it all.

@anden4380

Okay but riverbed are already add it is just some extra info and graphs

@laf
Member
laf commented Jan 10, 2017

We still need it

@laf laf added a commit to laf/librenms that referenced this issue Jan 16, 2017
@laf laf newdevice: Added more graphs for Riverbed devices #5170 cf14794
@crcro crcro added a commit to crcro/librenms that referenced this issue Jan 16, 2017
@crcro crcro riverbed extra informations #5170 989956b
@crcro crcro referenced this issue Jan 16, 2017
Merged

riverbed extra informations #5472

2 of 2 tasks complete
@laf laf closed this Jan 17, 2017
@anden4380

Thanks but i cannot find the graphs

@Rosiak
Contributor
Rosiak commented Jan 18, 2017

I'll try to take a look at it with @anden4380

@anden4380
RRDTool Command
rrdtool graph /tmp/s7NkHO4GER6ctCTZ.png --alt-autoscale-max --rigid -E --start 1484762700 --end 1484849100 --width 1728 --height 487 -c BACK#EEEEEE00 -c SHADEA#EEEEEE00 -c SHADEB#EEEEEE00 -c FONT#000000 -c CANVAS#FFFFFF00 -c GRID#a5a5a5 -c MGRID#FF9999 -c FRAME#5e5e5e -c ARROW#5e5e5e -R normal --font LEGEND:8:DejaVuSansMono --font AXIS:7:DejaVuSansMono --font-render-mode normal -l 0 -E --start 1484762700 --end 1484849100 --width 1728 --height 487 -c BACK#EEEEEE00 -c SHADEA#EEEEEE00 -c SHADEB#EEEEEE00 -c FONT#000000 -c CANVAS#FFFFFF00 -c GRID#a5a5a5 -c MGRID#FF9999 -c FRAME#5e5e5e -c ARROW#5e5e5e -R normal --font LEGEND:8:DejaVuSansMono --font AXIS:7:DejaVuSansMono --font-render-mode normal COMMENT:'Connect... Now Min Max Avg\l' COMMENT:'\l'

RRDTool Output
OK u:0.00 s:0.00 r:0.00
@Rosiak Rosiak reopened this Jan 19, 2017
@laf
Member
laf commented Jan 22, 2017

The graphs will show up in the Mib tab of graphs for the device:

image

@laf laf closed this Jan 22, 2017
@anden4380

It dont get any mib tab but i have now got a networktab but no data

image

@anden4380

Here are the RRD command

RRDTool Command
rrdtool graph /tmp/gdlKSWaw1dtJfdHI.png --alt-autoscale-max --rigid -E --start 1485071100 --end 1485157500 --width 2304 --height 667 -c BACK#EEEEEE00 -c SHADEA#EEEEEE00 -c SHADEB#EEEEEE00 -c FONT#000000 -c CANVAS#FFFFFF00 -c GRID#a5a5a5 -c MGRID#FF9999 -c FRAME#5e5e5e -c ARROW#5e5e5e -R normal --font LEGEND:8:DejaVuSansMono --font AXIS:7:DejaVuSansMono --font-render-mode normal -l 0 -E --start 1485071100 --end 1485157500 --width 2304 --height 667 -c BACK#EEEEEE00 -c SHADEA#EEEEEE00 -c SHADEB#EEEEEE00 -c FONT#000000 -c CANVAS#FFFFFF00 -c GRID#a5a5a5 -c MGRID#FF9999 -c FRAME#5e5e5e -c ARROW#5e5e5e -R normal --font LEGEND:8:DejaVuSansMono --font AXIS:7:DejaVuSansMono --font-render-mode normal COMMENT:'Connect... Now Min Max Avg\l' COMMENT:'\l'

RRDTool Output
OK u:0.00 s:0.00 r:0.00

@laf
Member
laf commented Jan 23, 2017

validate your install

@anden4380
@laf
Member
laf commented Jan 23, 2017

post the output of validate.

@anden4380
@laf
Member
laf commented Jan 23, 2017

run ./validate.php in the cli

@laf
Member
laf commented Jan 23, 2017

Please fix the warn and fail and then re-run and post the output.

@anden4380
@laf
Member
laf commented Jan 23, 2017

I don't know but validate doesn't have the correct output until you add the user you use to run librenms and fail, well yes that's a fail so fix it :)

@anden4380

Done still no data

image

@laf
Member
laf commented Jan 23, 2017

please post the output of:

./discovery.php -h HOSTNAME -d
./poller.php -h HOSTNAME -d -r -f

@laf laf reopened this Jan 23, 2017
@crcro
Contributor
crcro commented Jan 23, 2017 edited

from the print screen i see only 3 graphs: connections, datastore productivity and bandwidth passthrough but on the latest push there were 4 (those 3 and another one: optimization witch in your poller.txt seems to be with a typo: optimisation vs optimization).

my guess:
delete the existing riverbed_*.rrd
rediscover the device and wait for polling

@anden4380
@laf
Member
laf commented Jan 24, 2017 edited

Your poller output shows this is working fine.

Run rrdtool update rbtdkath01/riverbed_connections.rrd N:0:1:853:853:4080 --daemon unix:/var/run/rrdcached.sock

@anden4380
@laf
Member
laf commented Jan 25, 2017

Yes what? Did you run the command?

@anden4380
@laf
Member
laf commented Jan 25, 2017

I'm not sure what else to suggest. That means the rrd file was updated ok.

@anden4380
@laf
Member
laf commented Jan 25, 2017

You shouldn't, that was my pr.

@anden4380
@crcro
Contributor
crcro commented Jan 25, 2017
@anden4380
@laf laf added Needs-Info and removed New-Device labels Jan 25, 2017
@anden4380

IP: 212.130.149.235
Version 2c
Community string: librenms

i will connect it in 10 min :-)

@anden4380

it is now connect and will be to your are done :-)

@Rosiak
Contributor
Rosiak commented Jan 26, 2017

I'll pr a fix in a bit.

@Rosiak Rosiak referenced this issue Jan 26, 2017
Merged

fix: Fix Riverbed optimization polling #5622

2 of 2 tasks complete
@laf laf closed this in #5622 Jan 26, 2017
@anden4380

It is working thanks for your help :-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment