New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Toggle switches render incorrectly on Blink browsers when zoomed #5219

Closed
ghost opened this Issue Dec 21, 2016 · 6 comments

Comments

Projects
None yet
1 participant
@ghost

ghost commented Dec 21, 2016

DO NOT DELETE THIS INFORMATION.

Please read this information carefully.

GitHub issues is for feature requests or bugs, please do not post issues asking for help or how to do X, Y or Z.
You can use our irc channel ##librenms on freenode to ask questions or our community site.

  • Is your install up to date? Updating your install
    Please do not submit an issue if your install is not up to date within the last 24 hours or on a stable monthly release.
  • Please include all of the information between the ==================================== section of ./validate.php.
==========================================================
Component | Version
--------- | -------
LibreNMS  | 4898617ef52bed41c36ad33afc3a0af5570484c7
DB Schema | 153
PHP       | 7.0.14
MySQL     | 10.1.19-MariaDB
RRDTool   | 1.6.0
SNMP      | NET-SNMP 5.7.3
==========================================================
  • Please provide as much detail as possible.

Good day,

So on recent Blink powered browsers (Chromium and Opera have been tested), if page zoom is applied, then toggle switches render incorrectly. Here a picture is worth 1000 words so here's two screenshots of Chrome. The first at 125% which I normally run at and then at 100% (where the problem goes away). All of the toggles do this, but the about page was a good example.

This appears to be Webkit / blink specific as I tried this in Firefox and there the switches appeared normal.

out-fs8

@laf

This comment has been minimized.

Show comment
Hide comment
@laf

laf Dec 22, 2016

Member

This looks to be something that needs fixing in bootstrap-switch (Bttstrp/bootstrap-switch#602) - possibly related.

Member

laf commented Dec 22, 2016

This looks to be something that needs fixing in bootstrap-switch (Bttstrp/bootstrap-switch#602) - possibly related.

@laf

This comment has been minimized.

Show comment
Hide comment
@laf

laf Jan 30, 2017

Member

I've had a look more into this and one recommended fix doesn't work. I've also looked at an alternative to boostrap-switch and found http://www.bootstraptoggle.com/ but that is also not actively developed for 2 years and we could just come across more issues.

Not sure I see what else we can do at this stage :(

Member

laf commented Jan 30, 2017

I've had a look more into this and one recommended fix doesn't work. I've also looked at an alternative to boostrap-switch and found http://www.bootstraptoggle.com/ but that is also not actively developed for 2 years and we could just come across more issues.

Not sure I see what else we can do at this stage :(

@laf laf closed this Jan 30, 2017

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Jan 30, 2017

Yeah, I kinda figured this was going to be something Chrome had to fix. I just wanted to note it in case the question comes up from other folks (or there was some magical fix).

If you're zoomed more than 100%, it'll do this. So just tell people to un-zoom and move closer to the screen :-). Or you know, use Firefox.

ghost commented Jan 30, 2017

Yeah, I kinda figured this was going to be something Chrome had to fix. I just wanted to note it in case the question comes up from other folks (or there was some magical fix).

If you're zoomed more than 100%, it'll do this. So just tell people to un-zoom and move closer to the screen :-). Or you know, use Firefox.

@laf

This comment has been minimized.

Show comment
Hide comment
@laf

laf Jan 30, 2017

Member

Actually - do all toggle switches do this for you? Check some others like the edit device -> modules and see. Maybe we can fix.

Member

laf commented Jan 30, 2017

Actually - do all toggle switches do this for you? Check some others like the edit device -> modules and see. Maybe we can fix.

@laf laf reopened this Jan 30, 2017

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Jan 30, 2017

Actually you're right, the modules are fine on Device - modules. The one I notice which is broken is on the About page - the on/off for submitting stats.
screenshot-fs8

ghost commented Jan 30, 2017

Actually you're right, the modules are fine on Device - modules. The one I notice which is broken is on the About page - the on/off for submitting stats.
screenshot-fs8

@lock

This comment has been minimized.

Show comment
Hide comment
@lock

lock bot May 18, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed.

lock bot commented May 18, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed.

@lock lock bot locked as resolved and limited conversation to collaborators May 18, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.