New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

email_smtp_secure is not honored on TLS-enabled servers #5314

Closed
rdnn opened this Issue Jan 5, 2017 · 0 comments

Comments

Projects
None yet
2 participants
@rdnn
Contributor

rdnn commented Jan 5, 2017

DO NOT DELETE THIS INFORMATION.

Please read this information carefully.

GitHub issues is for feature requests or bugs, please do not post issues asking for help or how to do X, Y or Z.
You can use our irc channel ##librenms on freenode to ask questions or our community site.

  • Is your install up to date? Updating your install
    Please do not submit an issue if your install is not up to date within the last 24 hours or on a stable monthly release.
  • Please include all of the information between the ==================================== section of ./validate.php.
  • If you would like us to add a new device or your device is listed as Generic then please provide the information asked for here
  • Please provide as much detail as possible.
==========================================================
Component | Version
--------- | -------
LibreNMS  | 036f411e138bff272a15e9b64b7df9f3e7bdedbb
DB Schema | 152
PHP       | 5.6.29
MySQL     | 5.6.34
RRDTool   | 1.6.0
SNMP      | NET-SNMP 5.7.3
==========================================================

The SMTPAutoTLS option needs to be set to false and passed to PHPMailer to prevent it from opportunistically using TLS even when 'email_smtp_secure' is not set.

Reference PHPMailer/PHPMailer#550 (comment)

rdnn added a commit to rdnn/librenms that referenced this issue Jan 5, 2017

@rdnn rdnn changed the title from SMTP Alerts Fail to email_smtp_secure is not honored on TLS-enabled servers Jan 7, 2017

rdnn added a commit to rdnn/librenms that referenced this issue Jan 10, 2017

@laf laf closed this Jan 10, 2017

@lock lock bot locked as resolved and limited conversation to collaborators May 18, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.