New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

AKCP Environmental monitor missing graphs and icon #5396

Closed
eajohnson70 opened this Issue Jan 11, 2017 · 10 comments

Comments

Projects
None yet
3 participants
@eajohnson70

eajohnson70 commented Jan 11, 2017

DO NOT DELETE THIS INFORMATION.

Please read this information carefully.

GitHub issues is for feature requests or bugs, please do not post issues asking for help or how to do X, Y or Z.
You can use our irc channel ##librenms on freenode to ask questions or our community site.

Please confirm each of the sections below by putting an x in the box like [x].

  • Is your install up to date? Updating your install
    Please do not submit an issue if your install is not up to date within the last 24 hours or on a stable monthly release.
  • Please include all of the information between the ==================================== section of ./validate.php which you can run from the cli.
  • Unless your issue is for a WebUI fix or feature then please provide ALL info asked for here.
  • Please provide as much detail as possible.

Our AKCP sensorProbe4 is no longer displaying graphs as of an update on 2017-01-06 01:01:19

Recent events on this device:

2017-01-08 19:03:15 Device Icon changed generic => generic.png
2017-01-06 01:01:20 Sensor Deleted: temperature akcp 0 SE Temperature
2017-01-06 01:01:20 Sensor Deleted: temperature akcp 1 SW Temperature
2017-01-06 01:01:20 Sensor Deleted: temperature akcp 2 NW Temperature
2017-01-06 01:01:20 Sensor Deleted: temperature akcp 3 NE Temperature
2017-01-06 01:01:20 Sensor Deleted: humidity akcp 0 SE Humidity
2017-01-06 01:01:20 Sensor Deleted: humidity akcp 1 SW Humidity
2017-01-06 01:01:20 Sensor Deleted: humidity akcp 2 NW Humidity
2017-01-06 01:01:20 Sensor Deleted: humidity akcp 3 NE Humidity
2017-01-06 01:01:19 Device OS changed akcp => generic

Component Version
LibreNMS e95772e
DB Schema 153
PHP 5.6.29
MySQL 5.5.48
RRDTool 1.3.8
SNMP NET-SNMP 5.5
@laf

This comment has been minimized.

Show comment
Hide comment
@laf

laf Jan 11, 2017

Member

You've not provided the info in point 3.

Member

laf commented Jan 11, 2017

You've not provided the info in point 3.

@eajohnson70

This comment has been minimized.

Show comment
Hide comment
@eajohnson70

eajohnson70 Jan 11, 2017

eajohnson70 commented Jan 11, 2017

@Rosiak

This comment has been minimized.

Show comment
Hide comment
@Rosiak

Rosiak Jan 11, 2017

Contributor
./discovery.php -h HOSTNAME -d -m os
./poller.php -h HOSTNAME -r -f -d -m os
snmpbulkwalk -OUneb -v2c -c COMMUNITY HOSTNAME .
Contributor

Rosiak commented Jan 11, 2017

./discovery.php -h HOSTNAME -d -m os
./poller.php -h HOSTNAME -r -f -d -m os
snmpbulkwalk -OUneb -v2c -c COMMUNITY HOSTNAME .
@eajohnson70

This comment has been minimized.

Show comment
Hide comment
@eajohnson70

eajohnson70 commented Jan 11, 2017

@eajohnson70

This comment has been minimized.

Show comment
Hide comment

eajohnson70 commented Jan 11, 2017

@eajohnson70

This comment has been minimized.

Show comment
Hide comment
@eajohnson70

eajohnson70 Jan 11, 2017

snmpbulkwalk: Cannot send V2 PDU on V1 session

eajohnson70 commented Jan 11, 2017

snmpbulkwalk: Cannot send V2 PDU on V1 session

@eajohnson70

This comment has been minimized.

Show comment
Hide comment
@eajohnson70

eajohnson70 Jan 12, 2017

Looks like this happened before with an update and was remedied days later:

Eventlog entries
2017-01-12 05:29:44 System Device type changed environment => server
2017-01-08 19:03:15 System Device Icon changed generic => generic.png
2017-01-06 01:01:20 System Sensor Deleted: temperature akcp 0 SE Temperature
2017-01-06 01:01:20 System Sensor Deleted: temperature akcp 1 SW Temperature
2017-01-06 01:01:20 System Sensor Deleted: temperature akcp 2 NW Temperature
2017-01-06 01:01:20 System Sensor Deleted: temperature akcp 3 NE Temperature
2017-01-06 01:01:20 System Sensor Deleted: humidity akcp 0 SE Humidity
2017-01-06 01:01:20 System Sensor Deleted: humidity akcp 1 SW Humidity
2017-01-06 01:01:20 System Sensor Deleted: humidity akcp 2 NW Humidity
2017-01-06 01:01:20 System Sensor Deleted: humidity akcp 3 NE Humidity
2017-01-06 01:01:19 System Device OS changed akcp => generic
2017-01-06 01:01:19 System Device Icon changed akcp => generic
2017-01-01 13:01:45 System Sensor Added: humidity akcp 1 SW Humidity
2017-01-01 13:01:45 System Sensor Added: humidity akcp 2 NW Humidity
2017-01-01 13:01:45 System Sensor Added: humidity akcp 3 NE Humidity
2017-01-01 13:01:44 System Sensor Added: temperature akcp 2 NW Temperature
2017-01-01 13:01:44 System Sensor Added: temperature akcp 3 NE Temperature
2017-01-01 13:01:44 System Sensor Added: humidity akcp 0 SE Humidity
2017-01-01 13:01:43 System Sensor Added: temperature akcp 0 SE Temperature
2017-01-01 13:01:43 System Sensor Added: temperature akcp 1 SW Temperature
2017-01-01 13:01:42 System Device Icon changed generic => akcp
2016-12-29 00:55:55 System Sensor Deleted: temperature akcp 0 SE Temperature
2016-12-29 00:55:55 System Sensor Deleted: temperature akcp 1 SW Temperature
2016-12-29 00:55:55 System Sensor Deleted: temperature akcp 2 NW Temperature
2016-12-29 00:55:55 System Sensor Deleted: temperature akcp 3 NE Temperature
2016-12-29 00:55:55 System Sensor Deleted: humidity akcp 0 SE Humidity
2016-12-29 00:55:55 System Sensor Deleted: humidity akcp 1 SW Humidity
2016-12-29 00:55:55 System Sensor Deleted: humidity akcp 2 NW Humidity
2016-12-29 00:55:55 System Sensor Deleted: humidity akcp 3 NE Humidity
2016-12-29 00:55:54 System Device OS changed akcp => generic
2016-12-29 00:55:54 System Device Icon changed akcp => generic

eajohnson70 commented Jan 12, 2017

Looks like this happened before with an update and was remedied days later:

Eventlog entries
2017-01-12 05:29:44 System Device type changed environment => server
2017-01-08 19:03:15 System Device Icon changed generic => generic.png
2017-01-06 01:01:20 System Sensor Deleted: temperature akcp 0 SE Temperature
2017-01-06 01:01:20 System Sensor Deleted: temperature akcp 1 SW Temperature
2017-01-06 01:01:20 System Sensor Deleted: temperature akcp 2 NW Temperature
2017-01-06 01:01:20 System Sensor Deleted: temperature akcp 3 NE Temperature
2017-01-06 01:01:20 System Sensor Deleted: humidity akcp 0 SE Humidity
2017-01-06 01:01:20 System Sensor Deleted: humidity akcp 1 SW Humidity
2017-01-06 01:01:20 System Sensor Deleted: humidity akcp 2 NW Humidity
2017-01-06 01:01:20 System Sensor Deleted: humidity akcp 3 NE Humidity
2017-01-06 01:01:19 System Device OS changed akcp => generic
2017-01-06 01:01:19 System Device Icon changed akcp => generic
2017-01-01 13:01:45 System Sensor Added: humidity akcp 1 SW Humidity
2017-01-01 13:01:45 System Sensor Added: humidity akcp 2 NW Humidity
2017-01-01 13:01:45 System Sensor Added: humidity akcp 3 NE Humidity
2017-01-01 13:01:44 System Sensor Added: temperature akcp 2 NW Temperature
2017-01-01 13:01:44 System Sensor Added: temperature akcp 3 NE Temperature
2017-01-01 13:01:44 System Sensor Added: humidity akcp 0 SE Humidity
2017-01-01 13:01:43 System Sensor Added: temperature akcp 0 SE Temperature
2017-01-01 13:01:43 System Sensor Added: temperature akcp 1 SW Temperature
2017-01-01 13:01:42 System Device Icon changed generic => akcp
2016-12-29 00:55:55 System Sensor Deleted: temperature akcp 0 SE Temperature
2016-12-29 00:55:55 System Sensor Deleted: temperature akcp 1 SW Temperature
2016-12-29 00:55:55 System Sensor Deleted: temperature akcp 2 NW Temperature
2016-12-29 00:55:55 System Sensor Deleted: temperature akcp 3 NE Temperature
2016-12-29 00:55:55 System Sensor Deleted: humidity akcp 0 SE Humidity
2016-12-29 00:55:55 System Sensor Deleted: humidity akcp 1 SW Humidity
2016-12-29 00:55:55 System Sensor Deleted: humidity akcp 2 NW Humidity
2016-12-29 00:55:55 System Sensor Deleted: humidity akcp 3 NE Humidity
2016-12-29 00:55:54 System Device OS changed akcp => generic
2016-12-29 00:55:54 System Device Icon changed akcp => generic

@eajohnson70

This comment has been minimized.

Show comment
Hide comment
@eajohnson70

eajohnson70 Jan 13, 2017

Every time discovery.php runs the device type changes from environment to server as well.

eajohnson70 commented Jan 13, 2017

Every time discovery.php runs the device type changes from environment to server as well.

@eajohnson70

This comment has been minimized.

Show comment
Hide comment
@eajohnson70

eajohnson70 Jan 18, 2017

Applied patch per @laf on IRC and all's good now:

diff --git a/includes/definitions/akcp.yaml b/includes/definitions/akcp.yaml
index 52f86e3..3a3c5a1 100644
--- a/includes/definitions/akcp.yaml
+++ b/includes/definitions/akcp.yaml
@@ -6,3 +6,4 @@ over:
discovery:
- sysDescr:
- SensorProbe

  •    - sensorProbe4
    

eajohnson70 commented Jan 18, 2017

Applied patch per @laf on IRC and all's good now:

diff --git a/includes/definitions/akcp.yaml b/includes/definitions/akcp.yaml
index 52f86e3..3a3c5a1 100644
--- a/includes/definitions/akcp.yaml
+++ b/includes/definitions/akcp.yaml
@@ -6,3 +6,4 @@ over:
discovery:
- sysDescr:
- SensorProbe

  •    - sensorProbe4
    

@laf laf reopened this Jan 18, 2017

laf added a commit to laf/librenms that referenced this issue Jan 18, 2017

@laf laf referenced this issue Jan 18, 2017

Merged

newdevice: Updated akcp discovery definition #5396 #5501

2 of 2 tasks complete

@murrant murrant closed this in #5501 Jan 24, 2017

murrant added a commit that referenced this issue Jan 24, 2017

newdevice: Updated akcp discovery definition #5396 (#5501)
* newdevice: Updated akcp discovery definition #5396

* added unit tests
@lock

This comment has been minimized.

Show comment
Hide comment
@lock

lock bot May 18, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed.

lock bot commented May 18, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed.

@lock lock bot locked as resolved and limited conversation to collaborators May 18, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.